Xavier NX can not find my imu on gpio

Hi, I have been using Adafruit IMU (Adafruit 9-DOF Absolute Orientation IMU Fusion Breakout - BNO055 : ID 2472 : $34.95 : Adafruit Industries, Unique & fun DIY electronics and kits ) with Jetson TX2 and it worked very well. Now, I am trying to use it with Xavier NX but it did not seem to work. The imu was linked to NX by GPIO i2c pins. I use the pin 27 and 28 for SDA and SCL, which are for bus 1. However, when I do

sudo i2cdetect -y -r 1

It did not show anything.

Can anyone help?

hello AutoCar,

there’re two sets, pin-3/pin-5 and pin-27/pin-28 as I2C SDA and SCL on the [J12] 40-pin expansion header.
is this Adafruit IMU a 3.3V or 1.8V I2C device?
please check Jetson Xavier NX Product Design Guide of [Figure 12-1. I2C Connections] for reference,
thanks

@JerryChang Thank you for your post.

This is 3.3v.

I have tried both 3/5 and 27/29 pin with bus 1 and bus 8. They did not work.

Please not this device works fine on TX2. I am wonder what the difference is.

hello AutoCar,

may I know if there any error messages reported by kernel side?
please setup serial console and gather the logs in detail for reference, thanks

I2C0: SDA: 27, SCL: 28
I2C1: SDA: 3, SCL: 5

did you get any logs?

@JerryChang Could you tell me how to gather the logs?

Thanks,

hello AutoCar,

please refer to NVIDIA Jetson Xavier NX GPIO Header Pinout – JetsonHacks, you should setup a serial console via pin-8/10 with your host machine, the default baud-rate is 115200/8n1, please enable a terminal to gather the logs;
you may also check Jetson Nano Style – Serial Console – JetsonHacks for reference, thanks

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.