Xavier NX Dev Kit cannot be forced recovery

I have a brand new Xavier NX Dev Kit, and I tried to quick start without luck.

Following quick start guide,

  1. download SD Card image from this link
  2. write to card using etcher, content verification ok
  3. plug card to xavier nx
  4. plug hdmi, usb keyboard mosue
  5. plug original power supply with green LED on
  6. monitor always says no signal

Then I tried SDK Manager Force Recovery

  1. Plug sdcard
  2. plug micro USB cable (verified data ready)
  3. short jumper pin 9 and 10
  4. plug power with green LED on
  5. SDK Manager can detect my Xavier NX, i need to select P3668-0000
  6. I tried to remove or keep pin 9/10 jumper
  7. Tick accept agreement and input sudo password, I am blocked in the screen below.

What is default username and password ?
I read the online document, I cannot see pre-config option in the user interface now.
How to reset it to default username or password?
I tried ubuntu/ubuntu and nvidia/nvidia without luck

I tried to manual set my host IP to 192.168.55.100.
I cannot ping the board even both end is linked to same network switch box.

Hi,

You don’t put the board to force recovery mode when installing JetPack SDK.
Please just let it boot up normally and complete the system configuration wizard.

@DaveYYY Thx for your quick response.
My problem of SD Image method is in step 6 above, during this step, i didn’t short jumper pin 9 and 10, but i got black screen, and monitor said no signal. I cannot find a way to do “system configuration”

Then please follow this guide to do a whole re-flash:
https://docs.nvidia.com/sdk-manager/install-with-sdkm-jetson/index.html

I followed the same guide until this screen

I cannot see the option of “Auto or Manual”, and I cannot see “pre-config” option.
SDK Manager jump to the screenshot in my first post above, and I can only input username or password to click “install”

請問你確定你有follow教學上的步驟嗎?
可不可以螢幕錄影一下你到底做了什麼?

@DaveYYY I retried without Force Recovery jumper, and run all steps following your link above.
I cannot click install button too. The only difference is red “Could not detect a board” without force recovery jumper.

At this moment, LCD monitor still says no signal, so how to complete “system configuration wizard”? or how long should i wait to see LCD content? I wait few minutes without anything.

你可以把~/Downloads/nvidia/~/nvidia/底下的東西全部刪掉再重來嗎?

  1. Delete both download folder content
  2. Verify delete complete
(base) edward@edward-hp:~$ ls ~/nvidia
(base) edward@edward-hp:~$ ls ~/Downloads/nvidia/
(base) edward@edward-hp:~$ 
  1. Start download manager

  2. Without Force Recovery Jumper, it cannot be auto detect, so i choose it manually

  1. SDK Version is empty, but bottom right corner “Continue to Step 02” is clickable

  1. Click continue, and Tick Accept agreement

  1. Click continue to step 03, pop up to create new folders

  1. Click Create, and click “Continue to step 03” again, input sudo password, click ok

  1. then i arrive this page again

  1. check LCD monitor, no signal

還有那個部分需要錄影補充資料嗎?

第4步請你插上jumper再重來一次

  1. delete folder
(base) edward@edward-hp:~$ rm -rf ~/nvidia/
(base) edward@edward-hp:~$ rm -rf ~/Downloads/nvidia/
(base) edward@edward-hp:~$ ls ~/nvidia
ls: cannot access '/home/edward/nvidia': No such file or directory
(base) edward@edward-hp:~$ ls ~/Downloads/nvidia/
ls: cannot access '/home/edward/Downloads/nvidia/': No such file or directory
(base) edward@edward-hp:~$ 
  1. plug jumper, power on

  2. sdkmanager

  1. choose Dev Kit (SD Card version)

  1. Continue button is not clickable, so I need to manual select Target Hardware again

  1. Click Continue to Step 02

  1. Tick accept, Click Continue to Step 03

  1. Create folder

  1. Click Continue to Step 03 again, input sudo password

  1. arrive this page

  1. try ubuntu/ubuntu and nvidia/nvidia anyway, default IP is not available

  1. ping fail
(base) edward@edward-hp:~$ ping 192.168.55.1
PING 192.168.55.1 (192.168.55.1) 56(84) bytes of data.
From 192.168.55.2 icmp_seq=1 Destination Host Unreachable
From 192.168.55.2 icmp_seq=2 Destination Host Unreachable
From 192.168.55.2 icmp_seq=3 Destination Host Unreachable
^C
--- 192.168.55.1 ping statistics ---
5 packets transmitted, 0 received, +3 errors, 100% packet loss, time 4072ms
pipe 4
(base) edward@edward-hp:~$ 
  1. ifconfig, my manual config eth profile
(base) edward@edward-hp:~$ ifconfig eno2
eno2: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        inet 192.168.55.2  netmask 255.255.255.0  broadcast 192.168.55.255
        ether b4:7a:f1:ca:5c:f5  txqueuelen 1000  (Ethernet)
        RX packets 192  bytes 15414 (15.4 KB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 3401  bytes 655465 (655.4 KB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

(base) edward@edward-hp:~$ 

好,我不知道為什麼你的SDK VERSION是空白的…
那請你下載BSP之後用script手動燒

https://docs.nvidia.com/jetson/archives/r35.4.1/DeveloperGuide/text/IN/QuickStart.html

@DaveYYY 謝, 我先試一下, 因為較長時間,我之後再回覆

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.