Xavier NX Dev Kit partially flashed Jetpack 5.2, now won't flash, keyboard not working

I decided to update my Xavier NX so I flashed the latest 5.2 version to nvme, and the first part worked OK. The flash worked, but when it went to continue installing software it kept timing out.

Whether or not pins 9 and 10 are together and whether the usb is connected to the Linux host or not, the device boots but the USB keyboard is ignored, I can’t get to the boot or bios settings. Whilst the boot loader says it is waiting for esc or F11, all key presses are being ignored. The message includes “warning - test key used” if that is relevant. After the waiting time it boots to an Ubuntu “accept the Nvidia terms” screen but again keyboard and screen do nothing.

When trying to reflash with sdkmanager, if I select manual mode I never get to the point where continue or flash is selectable. In automatic mode I can select any of the disks but get an error message saying cannot make an ssh connection over the usb port.

I have /dev/ttyACM0 - can I connect to that via screen or similar? I also have usb to serial probe for debugging my old Nano.

Happy for suggestions on how to debug

ps -removing the M.2 disk just results in no boot at all

Continuing with USB0 tty serial connected, pressing esc does result in access to the bios settings. Booting emmc fails completely, and NVME goes to the accept terms but the NX refuses to accept the hardware keyboard and mouse to accept the terms, even though they work on Nano 4GB and Orin Nano. Maybe there is a bug on 5.2 latest? Or something went wrong during the flash.

A log of the boot in case that is useful

mylog3.txt (69.6 KB)

The journey continues

I formatted the nvme and reinserted it, but flashed emmc which refused to do manually and I had to dig out my old password and username. No idea why manual didn’t work, given I had pins 9-10 jumpered, but despite reboots with forced recovery jumper on it insisted on automatic. Is that a BIOS setting I missed?

OK, flashing to emmc I managed to do the initial flash, but then the install failed

Looks like some sort of collision with git repositories or repository key missing.

Tried this both with 5.2 and 5.1.1
NV_L4T_CUDA_TARGET_POST_INSTALL_COMP.log (7.2 KB)

Nope - emmc is too small, so going back to nvme but Jetpack 5.1.1 and try again

Using a different NVME drive, but still getting errors, now on the initial flash. Am thinking maybe it should not be ext4?

mylog4.txt (198.2 KB)

It looks like the Xavier NX Dev kit with JP 5 doesn’t like NVME nor USB. If anyone can help with the work around that would be much appreciated.

Hi,

Three things here:

  1. There is a bug in 5.1.1 that USB keyboard does not work in UEFI on Xavier NX, and it should have been fixed in 5.1.2.
  2. The log showed that the NVMe drive cannot be detected by the device. USB drives (/dev/sda1) may also be an option.
  3. You can just use
    sudo apt update && sudo apt install nvidia-jetpack to install JetPack stuff. SDK Manager is not strictly required here.

Thanks Dave

I need SDK Manager to flash the device nvme or usb, and seem to just go in circles. If device doesn’t boot I can’t load nvidia-jetpack.

I have the serial monitor cable and can abort a boot and change bootloaders etc. Is there a way to check devices from the bios prompt or some debug mode via the sdk manager?

Failing that does the M.2 nvme have to be formatted to any particular type? The device’s last boot was on 4. something so BIOS may not be latest, don’t know if ext4 is supported or not.

You can try formatting the NVMe drive as ext4 before flashing.