Xavier nx i2c not working on 5.0.2

hello everyone.

i want to do pan tilt camera on xavier nx with 5.0.2 jp
i installed library with perfecly and i tried my servo pan tilt set on jetson nano
there is no problem at the moment
but i tried on xavier nx not working.
for example code giving same as jetson nano but there is no any action on pan tilt set

i think doesnt work any i2c module because xavier dont connect any i2c module.
gpio pins not working on 5.0.1 DP on the past. i waited 5.0.2.
now gpio working and gpio blinking led.

how can i do. this is so important for me !
kernel_tegra194-p3668-0000-p3509-0000(1).dtb (316.2 KB)
kernel_tegra194-p3668-0000-p3509-0000.dtb (316.2 KB)
kernel_tegra194-p3668-0000-p3509-0000.dtb.sig (4 KB)
kernel_tegra194-p3668-0000-p3509-0000-user-custom.dtb (318.3 KB)

i tried with adxl 345 imu sensor same problem. i2c not working

hello ufukasill,

how you setup the connections to give the power supply?
are you using correct i2c bus, please double check the hardware connections.

İ controled my device a lot of time and bus and power.
All modules working on jetson Nano i have 4 jetson Nano. İ newly bought this xavier nx.

hello ufukasill,

may I know which pin on Xavier NX you’re used to communicate with this device?
please also access Jetson Xavier NX Product Design Guide, and please refer to [Figure 12-1. I2C Connections].

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.