Xavier NX, Jetpack 5.0.1, and UEFI - Boot from Network Woes

So I’ve got a weird one… recently installed system with 5.0.1 and no matter what I try with downgrading/upgrading/changing/altering the new UEFI bootloader, the system persists with trying to boot from PXE (IPv4 and then IPv6) and HTTP (IPv4 and then IPv6) before finally timing out and booting from the microsd card.

This is a Xavier NX Dev kit. It’s likely an earlier version of the dev kit but I don’t think that matters as I’m not aware of differences between any versions of the NX dev kits.

Of note, if I put in a completely different microSD card with a fresh 5.0.1 install, the system will boot up just fine as expected and not wait for ~5m before booting, trying every network adapter along the way. Also of note, the UEFI will not save any settings if altered for this particular card.

Before I finally throw in the towel and re-image this one particular card, I’m curious if anyone has suggestions for what I can try that I might not already have tried or if anyone has seen similar behavior with the new jetpack.


  1. Could you share your way to update the UEFI bootloader?

  2. Have you also tried the debug build of UEFI binary? It will dump full log in UEFI and tell us what is going on there.

Happy to! For #1, there were two methods for this board that were attempted. The first was via swapping in the microsd card from a system that had been upgraded to 5.0.1 via the new SD card image provided by NVIDIA (editing this for clarification). Once swapped, the system booted and then proceeded to perform an upgrade to the boot loader via a prompt that appeared on the gnome desktop (just said “reboot will be required”, IIRC).

The second method after that one produced these results (defaulting to booting from the network) was via downgrading the system using an 18.04 system and jetpack 4. That left the system in a state where it could be upgraded using another system with 20.04 and jetpack 5.0.1 back to UEFI. The jetson booted normally after that… until I swapped the original microsd card back into the system and it still wants to boot from the network.

I had thought that the UEFI loader was on the system and not on the microsd card but I guess I’m trying to work that out and what exactly it is doing and where it is trying to load from.

I am more than happy to try and grab a debug build and collect a log if you can tell me how.

Sorry for the late response, have you managed to get issue resolved or still need the support? Thanks

Sorry for late reply. The UEFI debug build can be generated by this method.

Thanks! We are still looking at it but working around the issue for the moment (unplugging the cable at boot to bypass the lengthy timeouts on the network boot).

It’s definitely odd as we haven’t seen this on any other boards and suspect it is at least in part due to this one board.

I did find out that that this build is based on the 5.0.1 NX SD card image and did not actually come from a Jetpack build so that might be playing a role here as well.

Appreciate you folks taking the time to help us!

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.