Xavier NX Jetpack 5.1 initrd massflash doesn't work

Yes, I have already tested downloading through two separate USB ports.
orin-nx-massflash-anomaly.log (41.1 KB)

@lhoang Can you take a look at it ?

What is this log that you upload? Is it flashing individually or flashing with multiple devices? It is because it is slightly different from the screenshot above so I want to ask.

@lhoang Flashing with two devices , the log of the failed one.

Can you try

to generate mfi image

sudo ./tools/kernel_flash/l4t_initrd_flash_internal.sh --no-flash --external-device nvme0n1p1 --sparse -p “-c bootloader/t186ref/cfg/flash_t234_qspi.xml --no-systemimg” -c ./tools/kernel_flash/flash_l4t_external.xml --massflash 5 --showlogs --network usb0 p3509-a02+p3767-0000 nvme0n1p1

to flash into nvme ssd

sudo ./tools/kernel_flash/l4t_initrd_flash.sh --flash-only --sparse --network usb0 --massflash 2 --showlogs

@lhoang Hi,
Generate mfi,

and flash two devices, one success, one fail

and the fail log.
orin-nx-massflash-anomaly.log (37.9 KB)

Maybe the USB cable is faulty can you replace the USB cable? Also can you upload both logs the failed one and the successful one.


the success one.
orin-nx-massflash-normal.log (38.2 KB)

the fail one.
orin-nx-massflash-anomaly.log (33.6 KB)

We tried two separate flash and it worked, so it had nothing to do with usb cables,I think.

@lhoang Thanks~
I fixed the problem. It’s a PC problem. I’ll just change the computer and flash them successfully. WTF !

Maybe your USB endpoints are overloaded with data

@lhoang not work on Ubuntu18.04, work on Ubuntu22.04.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.