Xavier NX RTC Module Shutoff Request

I have tried the mentioned changes in the .cfg files many times with no luck, the RTC battery charge module is still at 3.00 Volts.

Yes, we are still looking for guidance.

How did you flash the file?

We use the script right from the NVIDIA Toolkit:

nvsdkmanager_flash.sh --storage nvme0n1p1 (we are using an SSD)

Before this command is ran, I changed the .cfg file in tegra194-mb1-bct-pmic-p2888-0001-a04-E-0-p2822-0000.cfg with:

→ pmic.system.block[2].commands[1].0x04.0x01 = 0x00;

I even took from the T186 example and added pmic.system.block[2].count = 2; above the commands incase that was the issue.

Both times a no go. I know I am probably doing something wrong…any insight?



Please try to run with flash.sh directly. Use emmc case first. Share the flash log.

Here is one from yesterday…

flash_3-6_0_20230307-133411.log (63.1 KB)


I don’t need this one. I need the flash log from flash.sh. Not initrd flash log.

Sorry it has taken some time to generate this.

flash.log (435.9 KB)


P2888 is for jetson AGX xaiver… You are using xaiver NX…

OK, I looked in the log file and found that the Xavier NX is P3668. From this I went and located the file:

tegra194-mb1-bct-pmic-p3668-0001-a00.cfg (only file under P3668 for PMIC)

From Coin Cell Battery charging disable - #3 by TheBenjamin

The solution had said for T194, insert the following command:

pmic.system.block[2].commands[1].0x04.0x01 = 0x0;

I did the above and did notice during the FLASH process from a typo that I did have the right file now. Unfortunately, after a few test flashes, modifying and adding the above line did not work. I am still reading a 3.00 Volt potential.

Any ideas what I would be missing? Thanks,

Which path did you modify this file?


Did you remember to remove the copy under <home_directory>/Linux_for_Tegra/bootloader/?

I just did that, flashed again, confirmed the new file under /bootloader/ had added commands during FLASH and after it was completed, it is still at 3.00 Volts.

What is the result if you run this command after entering kernel?

i2cset -f -y 4 0x03c 0x04 0x08


i2cset -f -y 4 0x03c 0x04 0x00

Circuit is now shutoff. With both commands.

After a reboot though, the settings do not persist and the circuit is back on.

Ok, so does this meet your request ? I mean this “circuit is shutdown” behavior is what you want?

Yes, thank you for your help.


Please remove the whole “backup-battery {” property from below device tree and it shall give you a permanently shutdown in kernel.


Is there a guide that shows how to work with dtsi files? I have seen once you change them you have to recompile?

And or, is this something you have to do pre-flashing or something that can be updated in kernel post-flashing?


This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.