Xavier NX upgrade to JetPack 4.6 wifi card not recognized

Hi, I have Xavier NX devkit, I upgraded to Jetpack 4.6 from 4.5 using https://docs.nvidia.com/jetson/jetpack/install-jetpack/index.html#upgrade-jetpack.
and I cannot connect to wifi.

What I tried:

  • ifconfig does not list wlan0
  • lspci shows:

0004:01:00.0 Network controller: Realtek Semiconductor Co., Ltd. Device c822

output of uname -srm is:

Linux 4.9.201-tegra aarch64

Jetpack version is:

nvidia-jetpack is already the newest version (4.6-b199).

sudo lshw -C network:

*-network UNCLAIMED       
       description: Network controller
       product: Realtek Semiconductor Co., Ltd.
       vendor: Realtek Semiconductor Co., Ltd.
       physical id: 0
       bus info: pci@0004:01:00.0
       version: 00
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress cap_list
       configuration: latency=0
       resources: ioport:1000(size=256) memory:1740000000-174000ffff

I guess during upgrade to Jetpack 4.6 drivers for the card got deleted/corrupted, how can I get them?
(they are not here https://help.ubuntu.com/community/HardwareSupportComponentsWirelessNetworkCardsRealTek#PCI )

Okay, after half a day of browsing internet, I found the culprit!

True to its name, it was https://www.jetsonhacks.com/2020/05/29/jetson-xavier-nx-run-from-ssd/

Kernel modules could not be found, because they were on SSD.
I blindly followed advice at the bottom of that page:

Typically this involves copying the /boot* directory and /lib/modules// from the SSD to the SD card. If they are different, then modules load will be ‘tainted’, that is, the modules version will not match the kernel version.

It works now, but I have another question.

Did I do something that will have some weird consequences later on?

Feels like you are booting from the SDcard now but not the SSD anymore.