[Xavier NX] USB Compliance mode

Dear All,

In our carrier board, there is a M.2B Key connect to SOM’s usb3.0(without hub).


We’ve flash the officier’s jetpack r32.6.1 Image with few adjust at usb section.

  1. L4t Driver package
    https://developer.nvidia.com/embedded/l4t/r32_release_v6.1/t186/jetson_linux_r32.6.1_aarch64.tbz2
  2. L4t Root filesystem
    https://developer.nvidia.com/embedded/l4t/r32_release_v6.1/t186/tegra_linux_sample-root-filesystem_r32.6.1_aarch64.tbz2
  3. L4t source
    https://developer.nvidia.com/embedded/l4t/r32_release_v6.1/sources/t186/public_sources.tbz2
DTS adjust content
 diff -ruN tegra194-p3668-all-p3509-0000_default.dts tegra194-p3668-all-p3509-0000_usb3_compliance.dts
--- tegra194-p3668-all-p3509-0000_default.dts   2022-01-21 19:15:27.262212295 +0800
+++ tegra194-p3668-all-p3509-0000_usb3_compliance.dts   2022-01-21 19:19:38.927123814 +0800
@@ -7128,7 +7128,10 @@

                        usb3-2 {
                                status = "okay";
-                               nvidia,usb2-companion = <0x1>;
+//lanner++
+//                             nvidia,usb2-companion = <0x1>;
+                               nvidia,usb2-companion = <0x2>;
+//lanner--
                        };

                        usb3-3 {

DTS File(Revert from Linux_for_Tegra/kernel/dtb/)
tegra194-p3668-all-p3509-0000_usb3_compliance.dts (253.1 KB)

In this scenario, we’ve follow the ‘Jetson_Xavier_NX_Tuning_and_Compliance_Guide_Application_Note’
and tried to make the usb 3 enter compliance.

echo on > /sys/bus/usb/devices/usb1/power/control
echo on > /sys/bus/usb/devices/usb2/power/control

devmem2 0x03610440 w 0x10340

log file
Xavier_NX_usb_compliance_20220221_1547.log (41.2 KB)
But, there seems no signal from the M.2 B-Key so far.

Would you mind to give us some suggestion?

Best Regards,
MOMO Chen

Any dmesg to share?

Dear WayneWWW,

Sorry to reply late.
Update the log with the dmesg.
Xavier_NX_usb_compliance_20220223_1713.log (111.2 KB)

Best Regards,
MOMO Chen

Hi,

  1. If some usb 3 ports are not in use in your board, could you disable them in the device tree first? It looks like there are still 2x usb 3 ports in your setting.

[ 1.960540] tegra-xusb 3610000.xhci: Upgrade port 0 to USB3.0
[ 1.960547] tegra-xusb 3610000.xhci: Upgrade port 1 to USB3.0

  1. If we don’t run compliance mode, is your M.2 slot able to work?

Dear Sir,

Sorry to reply late, The compliance mode is working now.
It doesn’t need to disable any usb in the device tree.
It might be caused by fixture or other unknown reason before.

Best Regards,
MOMO Chen

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.