Xavier nx with JP 4.4.1 "build_opencv.sh 4.4.0" fails

I’m using xavier nx with JP 4.4.1 and trying to install open cv from GitHub - mdegans/nano_build_opencv: Build OpenCV on Nvidia Jetson Nano using the ./build_opencv.sh 4.4.0 command.

It fails:

$ sudo ./build_opencv.sh 4.4.0
It appears an existing build exists in /tmp/build_opencv
Do you wish to remove temporary build files in /tmp/build_opencv ?
(Doing so may make running tests on the build later impossible)
Y/N y
Installing build dependencies.
Hit:1 Index of /ubuntu-ports bionic InRelease
Hit:2 Index of /ubuntu-ports bionic-updates InRelease
Hit:3 Index of /ubuntu-ports bionic-backports InRelease
Hit:4 Index of /ubuntu-ports bionic-security InRelease
Hit:5 https://repo.download.nvidia.com/jetson/common r32.4 InRelease
Get:6 https://repo.download.nvidia.com/jetson/t194 r32.4 InRelease [2,565 B]
Fetched 2,565 B in 3s (949 B/s)
Reading package lists… Done
Reading package lists… Done
Building dependency tree
Reading state information… Done
Calculating upgrade… Done
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
1 not fully installed or removed.
After this operation, 0 B of additional disk space will be used.
Setting up nvidia-l4t-bootloader (32.4.4-20201027211332) …
Starting bootloader post-install procedure.
ERROR. Procedure for bootloader update FAILED.
Cannot install package. Exiting…
dpkg: error processing package nvidia-l4t-bootloader (–configure):
installed nvidia-l4t-bootloader package post-installation script subprocess returned error exit status 1
Errors were encountered while processing:
E: Sub-process /usr/bin/dpkg returned an error code (1)

any help?



Please check this topic as a reference.

It looks like there is an apt upgrade in the script.
Could you remove the command and try it again?


I used this one and it solved this problem:

I don’t know why it solved it or what was the problem.
Thank you for your help!

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.