Xavier NX works with TV but not with HDMI monitor

Hello all. I have recently purchased a Xavier NX development kit and after flashing with the jetpack 4.4, the board came on but there was no output on the HDMI monitor. When I connected the board to a TV via HDMI cable it worked fine. Is there any solution for this? Is there a driver missing. The monitor is a Lepow Z1-Gamut (2020) 15.6 Inch FHD 1080P. The monitor also works fine when connected to a laptop via HDMI.

Is the monitor connected to HDMI? I am guessing so, but some other types of connection are not supported. In the case of using HDMI, what do you see from:

sudo -s
cat `find /sys -name 'edid'
exit

If that has data, then the HDMI is detected and it is possible to auto configure.

The driver has some restrictions not found in a full desktop video card, and there are modes which might be ignored. In order to know what the driver thinks of each mode you’ll want to add a debug option to the “/etc/X11/xorg.conf” and then reboot and post the log (you can use ssh or serial console to get this; perhaps even CTRL-ALT-F2 or F3). The file modification is to Section "Device", where you will add one line:

Section "Device"
   ...
   Option "ModeDebug"
   ...

With that in place you will have verbose logs after reboot. The log will probably be “/var/log/Xorg.0.log”, but in some cases it might be “/var/log/Xorg.1.log” (a timestamp on the file will let you know which one is most recent, “ls -l /var/log/Xorg.*.log”). Copy that somewhere, change the file suffix to “.txt”, and attach to the forum. Then we’ll know what the driver thinks of all modes (irrelevant if no EDID exists, but otherwise this should answer why it does or does not work on that monitor).