Xavier ota from 3.7.2 to 5.0.2, log display update successfully,but can't start right

Hi,
I follow the step of Software Packages and the Update Mechanism — Jetson Linux<br/>Developer Guide 34.1 documentation to update the xavier board from 3.7.2 to 5.0.2.The log is as following.
The log display that “OTA is successfully completed”, but when reboot, the log display that “ASSERT [DxeCore] /dvs/git/dirty/git-master_linux/out/nvidia/bootloader/uefi/Jetson_RELEASE/edk2/MdeModulePkg/Core/Dxe/DxeMain/DxeMain.c(554): !(((INTN)(RETURN_STATUS)(Status)) < 0)”.
The attachment is the log.
xavier-cant-start-after-image-base-update-from-3.7.2-to-5.0.2.txt (265.2 KB)
Thanks

Hi,
I reviewed the log, and discover a error:“Error: create esp mount directory /opt/nvidia/esp failed.” Does it has any impact on the update process.
Thanks

Hi,
When I re-burn the xavier 5.0.2, there is a new appearance. After reboot of ota failed, I use flash.sh to burn the same xavier module 5.0.2 and the xavier reboot failed with the same error “ASSERT [DxeCore] /dvs/git/dirty/git-master_linux/out/nvidia/bootloader/uefi/Jetson_RELEASE/edk2/MdeModulePkg/Core/Dxe/DxeMain/DxeMain.c(554): !(((INTN)(RETURN_STATUS)(Status)) < 0)”.
Before ota update, there is no error of reboot after the burn of flash.sh.
Thanks

Is there a NVME drive on your board?

Yes

please remove the nvme and see if you can boot then.

Hi,
I removed the nvme device, and the same error is appeared.
Thanks.

Hi,

Sorry that I made a mistake here.

This error from UEFI means some partition error happened and cannot recovered.

ASSERT [DxeCore] /dvs/git/dirty/git-master_linux/out/nvidia/bootloader/uefi/Jetson_RELEASE/edk2/MdeModulePkg/Core/Dxe/DxeMain/DxeMain.c(554): !(((INTN)(RETURN_STATUS)(Status)) < 0)

  1. Was your previous system based on emmc? or you boot from external drive?

  2. Was this able to reproduced with other device too?

Hi,
I tested another xavier, and found that if I burned the xavier with flash.sh,the same error is also appeared. So I changed the dtb and burned the xavier again, the result is that the xavier can reboot rightly. The attachment is the right and wrong dtb.
tegra194-p2888-0001-p2822-0000.wrong.dtb (372.9 KB)
tegra194-p2888-0001-p2822-0000.right.dtb (367.9 KB)
When the xavier can reboot rightly, I replaced the /boot/dtb/kernel_tegra194-p2888-0001-p2822-0000.dtb with the wrong dtb and the xavier can also reboot rightly.

Err… actually I don’t know what your are talking about…

Why do we suddenly have good and wrong dtb here? Are you saying that use the wrong dtb would cause the board fail to flash?

Hi,
I can all burn successfully the xavier with the right and wrong dtb.
Because the need of camera, I have modified the dtb and generated the wrong dtb.
The wrong dtb leads to the error of reboot that "ASSERT [DxeCore] /dvs/git/dirty/git-master_linux/out/nvidia/bootloader/uefi/Jetson_RELEASE/edk2/MdeModulePkg/Core/Dxe/DxeMain/DxeMain.c(554): !(((INTN)(RETURN_STATUS)(Status)) < 0) "

Thanks

So do you still need our help on this issue? If so, how about you shared what you modified in your wrong dtb?

Hi,
Yes, I need you help.
I don’t know how the dtb can lead to some partition error.
You can use dtc to convert dtb to dts to know what is modified.
Thanks

可以麻煩你就直接寫出來你加在dtb裡面的patch是哪些東西嗎?

說實話我們沒有時間一行一行比對你加了哪些東西. 畢竟這是你加的東西, 你直接回答的話也會比較快速吧? 謝謝

Could you please directly tell us what patch you add to your dtb?
To tell the truth, we have not time to compare what you added in each line.

Hi,
The modified place is too much. I descriped it briefly. I add the camera number to 8, only left the camera of tegra194-camera-e3326-a00.dtsi and the related files, delete all the other camera.
The attachment is the patch.
xavier-devicetree-5.0.2.patch (458.7 KB)
Thanks

So if we use your “wrong dtb” to flash devkit, we shall see the same error on our side?

Yes

Is the “right” dtb also with any of your patch? or it is pure one from jetpack?

Hi,
The “right” dtb is not with any of my patch.I just modified the “mode” of “usb2-0” from “otg” to “host” in the pure one from jetpack.
Thanks

1 Like

hello tianyi2,

please refer to developer guide, To Create and Apply a DTB Overlay File to implement your device tree overlay.

BTW,
can 8 camera register to file system successfully? it looks your camera module4/5 are having duplicate position settings as camera module6/7.