xavier: spi enable dma(default)

Hi, all:
I am use spi2 to driver a device. everything is ok. The device use interrupt and the interrupt is very frequently. So the usage rate of CPU 0 is very high.
I want enable spi2 dma default. How should I do to let dma enabled? I can not find the spi dma message from kernel log(dmesg).

spi2: spi@3230000 {
                compatible = "nvidia,tegra186-spi";
                reg = <0x0 0x03230000 0x0 0x10000>;
                interrupts = <0 38 0x04>;
                #address-cells = <1>;
                #size-cells = <0>;
                iommus = <&smmu TEGRA_SID_GPCDMA_0>;
                dmas = <&gpcdma 17>, <&gpcdma 17>;
                dma-names = "rx", "tx";
                spi-max-frequency = <65000000>;
                nvidia,clk-parents = "pll_p", "clk_m";
                clocks = <&bpmp_clks TEGRA194_CLK_SPI3>,
                        <&bpmp_clks TEGRA194_CLK_PLLP_OUT0>,
                        <&bpmp_clks TEGRA194_CLK_CLK_M>;
                clock-names = "spi", "pll_p", "clk_m";
                resets = <&bpmp_resets TEGRA194_RESET_SPI3>;
                reset-names = "spi";
                status = "disabled";
                status = "okay";
                max-freq = <24000000>;
                        compatible = "wkmic,wk2124spi";
                        reg = <0>;
                        spi-max-frequency = <10000000>;
                        irq_gpio = <&tegra_main_gpio TEGRA194_MAIN_GPIO(T, 0) IRQ_TYPE_LEVEL_LOW>;



The transfer size greater than FIFO size driver internally would do DMA transfers and for smaller size it will be PIO.

HI, ShaneCCC:
Thanks for you replied.
Can you tell me how to modify the FIFO size?

Did you use spidev_test the -g parameter config the transfer size.

HI, ShaneCCC:
I am not use the command spidev_test. Can you tell me how should I do?
Thank you very much.

Looks like you didn’t use spidev_test may need to download the source and build it otherwise you need to check your current transfer buffer size more than 256 bytes.