XFI mode startup failure

Hello NVIDIA engineers:

I am experiencing a boot failure issue when using UPHY_RX/TX_6 as XFI mode to connect to a switch:
errLog.txt (34.4 KB)


��Unhandled Exception in EL3.
x30 = 0x0000000050000d00
x0 = 0x0000000000000000
x1 = 0x00000000be000011
x2 = 0x0000000000000000
x3 = 0x0000000000000011
x4 = 0x000000102cd5d75c
x5 = 0x000000102d1fe8bc
x6 = 0x000000004a000000
x7 = 0x000000004a000000
x8 = 0xffffffffffffffe0
x9 = 0x000000005001c380
x10 = 0x55aaa055071dbd35
x11 = 0x55aa8255ce1abfe1
x12 = 0x0000000000000000

Usage Environment:
Customized board + Jetson AGX Orin L4T R35.4.1

p3701.conf.common:
ODMDATA=“gbe-uphy-config-22,hsstp-lane-map-3,nvhs-uphy-config-1,hsio-uphy-config-0,gbe0-enable-10g”;

Is this kind of problem something that L4T needs to be configured to start properly?

The issue is not related to XFI.

The problem is you changed the nvhs-uphy-config-0 to nvhs-uphy-config-1 and I am not sure about your purpose.

Because my customized version uses the Orin as an EndPoint to communicate with another Orin over PCIE.

Which board config are you using? Sounds like you remove some overlay dtbo so that pcie endpoint mode does not get enabled in the device tree.

What does “Board config” mean?
My burn command:
sudo . /flash.sh jetson-agx-orin-devkit mmcblk0p1

Also the PCIE should be unaffected, I’ve been using the following configuration before debugging the XFI and Orin is booting fine:
ODMDATA=“gbe-uphy-config-0,hsstp-lane-map-3,nvhs-uphy-config-1,hsio-uphy-config-0”;

jetson-agx-orin-devkit is not a magic string. It means “jetson-agx-orin-devkit.conf” under your Linux_for_Tegra.

You can restore everything just back to default jetpack version first and test again.
I don’t really know why you are configuring XFI by yourself because this thing was already enabled in default jetpack image.

Also, if you really want us to check what happened, you need to enable full UEFI log by rebuilding UEFI.
But as I said, I feel that is wasting time as XFI does not need extra configuration at all.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.