Xlib: extension "NV-GLX" missing on display ":1"

I’ve tried to use the LGD ver 2.2 in two different Ubuntu systems but the interceptor is printing the following error:

Xlib:  extension "NV-GLX" missing on display ":1"

Then the application fails to create a GL context.

I normally launch my application using LD_PRELOAD=~/.tgd/libs/libNvidia_gfx_debugger.so

The only common about the two systems is the driver version which is the 387.34

Any ideas on how to workaround/fix this problem?

Hi,

Can we have a sample application to reproduce?
Can you reproduce this issue on other applications?
Is your driver downloaded from nvidia official website or provided in ubuntu?

Thanks.

Thank you for your quick reply.

Apparently the issue is reproducible on more GL applications including glxgears.

I got the driver from this Ubuntu PPA: https://launchpad.net/~graphics-drivers/+archive/ubuntu/ppa

I’ll try to install one from your website and see if the error persists.

Please note that I’ve tried version 381 from the same Ubuntu PPA and LGD worked without issues.

Hi,

Thanks for your reply.
Please let us know if this issue still happens on official nvidia driver. Thanks.

Hi,

I can confirm that this is an issue with driver version 387 obtained from the Ubuntu PPA.
Using the same source (https://launchpad.net/~graphics-drivers/+archive/ubuntu/ppa) version 381 is working perfectly fine.

I did not test the official NVIDIA driver, though I hope this information is still useful to track down the problem.

Hi grunz,

Thanks for the information.
Please note that drivers other than official Nvidia ones are not guaranteed to work with LGD.

@codym_nv Installing the official nvidia driver via “NVIDIA-Linux-x86_64-384.111.run” did indeed solve the problem for me.

But now I want to install CUDA and since Ubuntu does not know the nvidia driver is already installed it wants to install it’s own nvidia driver before installing CUDA.

So installing the official driver by hand creates a real mess and cannot be considered a solution to me.

Sorry for the late update.

Using the official NVIDIA-Linux-x86_64-384.111.run LGD works just fine for me as well. Installing the newly created 384.111 package from this Ubuntu PPA doesn’t work.

It seems like a packaging issue. Will file a bug.

UPDATE: This is the bug report if anyone wants to add more info https://lists.launchpad.net/graphics-drivers-testers/msg00097.html

Hi Max,
If you want to install CUDA as well, please also download CUDA package from Nvidia official site, which contains graphics driver.
Please make sure driver installed from Ubuntu PPA is removed before installing CUDA.

Thanks.

Greetings,

I am having the exact same issue, trying to debug an nvidia core lib crash in a call to glBufferData and followed the guide to run nvidia-gfx-debugger using version 2.2. The app runs until an X11 window creation call is made with the error:

Xlib:  extension "NV-GLX" missing on display ":0".

Running the same app however without going through nvidia-gfx-debugger launches just fine. I am using Nvidia driver 384.111 with Linux-x86_64 and this is also a Cuda enabled application. Is there a missing step I need to do ?

Update:
Graphics card is a Geforce Gtx 1080 with vbios version 86.04.3b.00.54
Linux Version: Ubuntu 16.04.2 LTS

My setup settings:
https://ibb.co/ijNMG6
Setup.png

Update: I just reinstalled the drivers from Nvidia’s site and everything seems to be working for me… 384.111 with 2.2