Xorg blank screen with nVIDIA drivers - not just 367, and with unused card

I run Kubuntu 16.04 (just installed it from the ISO). My computer has on-chip Intel graphics, which is what I use for the display. I also have a GTX 650 Ti Boost card which I DO NOT WANT TO USE for display (just for CUDA work).

  • When nVIDIA driver 361.62 or 367.35 is installed, Xorg loads to a black screen (but when I run binaries which use CUDA run fine).
  • When nVIDIA driver 361.62 or 367.35 is not installed, Xorg loads fine; it loads the nouveau modules (even though supposedly I don't need them) - but CUDA apps don't run.

The Xorg error with the nVIDIA driver installed is:

(EE) NOUVEAU(G0): [XvMC] Failed to initialize extension.
...
(EE) Failed to initialize GLX extension (Compatible NVIDIA X driver not found)

If I uninstall the nVIDIA driver, X works properly again (will quote some log messages here soon).

Note: I’ve just read this thread: black screen with 367.35 but I think I can’t use the “metamodes” workaround, since I don’t actually have an X Screen related to the nVIDIA X device for which to set anything.

PS - I’ve also experienced the same problem with Debian Stretch and kernel 4.7.0.