Xorg server 1.18.0 (F23) fails to start and system hangs with Quadro M3000M on 352.79

After having followed the instructions in http://www.if-not-true-then-false.com/2015/fedora-nvidia-guide/, I installed the latest stable Linux driver (352.79) on my new Lenovo Thinkpad P70 w/ Quadro M3000M card, running on Fedora 23 (x86_64). With the nouveau driver disabled/blacklisted and with ‘Discrete Mode’ set in the BIOS (i.e. as opposed to “Hybrid Mode”, enabling Optimus), when I attempt to boot to X, the system hangs with the CapsLock key blinking.

I can boot to RC3 fine w/ the nvidia driver loaded - but not RC5. When I tried starting X from RC3 (i.e. w/ startx -- -logverbose 6), the same behavior (CapsLock blinking, system hangs) occurred. I could not SSH into the system to capture the nvidia-bug-report.log.gz: I was only able to capture it when running w/out X.

I have tried installing addt’l drivers (long-lived, short-lived, and beta) with no success. I’ve also tried multiple kernels (w/ and w/out noapic/acpi=off flags), tested using legacy BIOS and newer UEFI, and tested against addt’l distros (mainly CentOS 7). The nouveau driver (in conjunction w/ Optimus aka. “Hybrid mode” in BIOS) seems to work fine on kernel 4.4.0 (more unstable on earlier versions), but the proprietary NVIDIA driver has not yet worked. Any help would be greatly appreciated.

–A.
nvidia-bug-report.log.gz (83.4 KB)
nvidia-installer.log (5.41 KB)

.

From your log:

Jan 27 15:47:25 styx kernel: NVRM: Can't find an IRQ for your NVIDIA card!
Jan 27 15:47:25 styx kernel: NVRM: Please check your BIOS settings.
Jan 27 15:47:25 styx kernel: NVRM: [Plug & Play OS] should be set to NO
Jan 27 15:47:25 styx kernel: NVRM: [Assign IRQ to VGA] should be set to YES 
Jan 27 15:47:25 styx kernel: NVRM: The NVIDIA probe routine failed for 1 device(s).
Jan 27 15:47:25 styx kernel: NVRM: None of the NVIDIA graphics adapters were initialized!
Jan 27 15:47:25 styx kernel: NVRM: NVIDIA init module failed!

Thanks, tuke81. None of my BIOS’s available settings include the ability to toggle "Plug & Play OS’ or setting ‘IRQ to VGA’. I’ve disabled all power management features and all security features, and I’ve also used legacy BIOS instead of uEFI. No BIOS config permutation has yielded results unfortunately.

Hmh try boot parameter pci=biosirq, disabling acpi on laptop is in general bad idea. Another possibly is problems with msi_interrupts, but if I remember correctly the error is a bit different.

I think pci=biosirq is a 32-bit kernel parameter. I’m running a 64-bit system, and I get an error like ‘pci=biosirq not valid option’ when attempting to use it. I’ve tried similar parameters to no avail.

Hmm you might be right. Only other boot parameter which come in my mind is irqpoll, though you do get irq for nvidia device if you use nouveau so it should not be irq routing problem(and in log your graphics card with nvidia binary driver should have irq 16, but yet it does not show in /proc/interrupts).

Other thing that you might try, is disabling MSI from nvidia kernel loading(open live session, use chroot and add NVreg_EnableMSI=0 to nvidia kernel module loading conf in folder /etc/modprobe.d/(i.e. gentoo’s wiki)).

Hi tuke81. Thank you for your suggestions. I tried both enabling irqpoll at boot and disabling MSI within xorg.conf with no success. At this point does it sound like a firmware issue?

Did you eventually get this to work? I ordered a similar Thinkbook P70 and would like to install CentOS 7 on it.