xrandr brightness is incorrect for drivers after 304.64 for GeForce 330M

Linking to my old post: https://devtalk.nvidia.com/default/topic/537861/?comment=3784388

Now that I have spent a long time figuring this all out, drivers after 304.64 for my graphics adapter set the wrong brightness when using xrandr. Using xbacklight -set 100 sets the brightness one value below the old method /sys/power/backlight/acpi_video0. I implemented a hack and recompiled my kde-workspace-bin so powerdevil (the kde power management service) will never try to use xrandr for the brightness. This needs to be fixed so it works correctly, it is not a problem with KDE.

EDIT: If anyone else is having brightess problems please try using xbacklight -set 100 and seeing if it sets 100% brightness or going into /sys/power/backlight and trying there.

I decided to attach a debug log hoping that will somehow get some attention to this bug but it seems to come out blank.

I see this at the console:

$ sudo nvidia-bug-report.sh 
[sudo] password for user: 

nvidia-bug-report.sh will now collect information about your
system and create the file 'nvidia-bug-report.log.gz' in the current
directory.  It may take several seconds to run.  In some
cases, it may hang trying to capture data generated dynamically
by the Linux kernel and/or the NVIDIA kernel module.  While
the bug report log file will be incomplete if this happens, it
may still contain enough data to diagnose your problem.

Please include the 'nvidia-bug-report.log.gz' log file when reporting
your bug via the NVIDIA Linux forum (see devtalk.nvidia.com)
or by sending email to 'linux-bugs@nvidia.com'.

Running nvidia-bug-report.sh...

If the bug report script hangs after this point consider running with
--safe-mode command line argument.


And the generated log file seems pretty bare


Start of NVIDIA bug report log file.  Please include this file, along
with a detailed description of your problem, when reporting a graphics
driver bug via the NVIDIA Linux forum (see devtalk.nvidia.com)
or by sending email to 'linux-bugs@nvidia.com'.

nvidia-bug-report.sh Version: 15313852

Date: Sunday 14 July  16:23:45 EST 2013
uname: Linux 3.2.0-4-amd64 #1 SMP Debian 3.2.46-1 x86_64 GNU/Linux
command line flags:

Note: I removed my host name from the output so that is working fine.


sorry. deleting my wrong comment

I’m not sure what that has to do with my brightness issue or is this related to the bug report script not working?

Filed Bug 1357799 to track this issue.

Thanks for filing a bug, is there anyway for me as an end user to view the bug?

The bug tracker is not available publicly, but you can ask us for status updates.

Can you please actually attach the nvidia-bug-report.log.gz file? It consists of separate concatenated gzip segments, so if you’re using a tool to view it that doesn’t handle those correctly, that might explain why it appears to be truncated.

We tried to reproduce this issue with Toshiba Qosimo X505 GT 216 and Qosmio F755 notebooks with Debian 7.1 Wheezy+ KDE:4.8.4.

We are not able to reproduce this issue. We able to adjust the brightness using Fn key without any issue with reported driver.

Seems issue specific to particular model. Waiting for NVIDIA-BUG-REPORT …

Will post bug report file shortly

This was indeed the problem, file attached. If anymore information is needed just ask, happy to provide it.
nvidia-bug-report.log.gz (94.3 KB)

Any chance of a status update?

We’ve narrowed it down a bit, but haven’t quite determined the root cause of the problem yet.

That’s good to hear is there anyway I can prevent the driver from exposing the control? aka disable it on the driver so I don’t need to recompile the package every update?

Still broken as of 331.38, will this ever get fixed?

FYI using nvidia-settings -a BacklightBrightness=100 shows the same problem as xbacklight -set 100.

Also is there anyway to stop the nvidia driver exposing the backlight brightness control so I could at least stop hacking up and recompiling packages!?

Still broken in 334.21…

Still broken in 340.58, over a year since I reported it.

Much broken such wait, wow.