Xubuntu 20.04 Focal Fossa L4T R32.3.1 - Custom Image for the Jetson Nano

BTW Windows10 arm64 works on the Nvidia-Jetson-Nano under KVM qemu-system-aarch64 :)

1 Like

Pretty cool!, I assumed it would however I’ve been waiting for the development of virtio-gpu drivers for windows 10 on arm so that we can have gpu acceleration as well , that would be fun to play with.

Check out the video I posted here for some kvm with gpu acceleration Jetson nano - KVM Acceleration - Android VM / Emulation Demo

1 Like

I saw your videos already :) they are very nice and I like the android idea in qemu very much.
Im more interested in gpu acceleration on NetBSD arm64 really … this is something I wanted to test/try more - is there any specifics for the GPU part to add to the standard qemu loader sripts ? I can use the config you showed for the Android

When compiling qemu make sure to add --enable-opengl --enable-virglrenderer --enable-sdl .

Also make sure to compile or install libvirglrenderer1 and libvirglrenderer-dev before compiling qemu.

With this you can even enable gpu acceleration on an armhf userspace with arm64 guest kernel

Yeah I did for the 5.0.50 qemu build as soon as I loaded your image on the nanojet

This image looks great, but does it support the Jetson nano b01 version?

I tried it on my B01 version and the Ubiquity installer worked fine, but on the next reboot the screen showed some errors and hangs.

[ 28.340981] nvgpu: 57000000.gpu gk20a_pmu_isr:724 [ERR] pmu exterr intr not implemented. Clearing interrupt.
[ 28.353108] nvgpu: 57000000.gpu gk20a_falcon_dump_stats:560 [ERR] <<< FALCON id-0 DEBUG INFORMATION - START >>>
[ 28.364619] nvgpu: 57000000.gpu gk20a_falcon_dump_imblk:504 [ERR] FALCON IMEM BLK MAPPING (PA->VA) (96 TOTAL):
[ 28.376018] nvgpu: 57000000.gpu gk20a_falcon_dump_imblk:518 [ERR] 0x00: 0x01000000 0x01000100 0x01000200 0x01000300
[ 28.387952] nvgpu: 57000000.gpu gk20a_falcon_dump_imblk:520 [ERR] 0x04: 0x01000400 0x01000500 0x01000600 0x01000700

The image was built for the developer kit rev. 200 / A02 however I believe the dtb for the BO1 is included in the /boot directory so you might be able to edit the extlinux.conf in the first section where it says :

LABEL primary
MENU LABEL primary kernel
LINUX /boot/Image
INITRD /boot/initrd
APPEND ${cbootargs}

If you add the line: FDT /boot/“your boards correct.dtb”

Replacing the section in quotes with the correct dtb file for your board.

That may work, however kvm support won’t.

You shouldn’t see any error messages after your second boot. On the first full boot there’s a grub related message but that is gone afterwards.

Hope that helps , I don’t know much about the files related to your board so maybe someone with more experience can help out.

The image provided by nvidia supports both versions without modification doesn’t it? So I’m not sure what mine would be missing that would prevent this.

Hi, I wanted to try your image but unfortunately my screen remains black during boot. The screen (1900x1200) is connected via displayport. If I try another sdcard with an official nvidia image it works properly. So it seems not to be an hardware issue.

Hi Jen’s , Im Sorry to hear that.

It must have something to do with the ubiquity installer, for some reason on this version of Ubuntu the ubiquity-dm installer is unable to start an xserver using the jetsons glx drivers so it ends up falling back to a default fbdev xorg.conf. This is the reason why I had to make the ubiquity installer do a full reboot after the initial setup.

On second boot everything loads correctly and lightdm has no problem starting the xserver. I spent quite a bit of time trying to figure out what the issue was basically pulling my hair out because I created an Ubuntu 19.10 image that also used the ubiquity installer and it worked perfectly.

So in the end I just ended up modifying the oem-config script to reboot after the setup completes. I’ll try to look into the issue further but for now if you have a second display with HDMI that you could use to complete the initial user setup I’m sure that once the device reboots the display port will be functioning as it should .

Does the green nvidia logo come on the display before it goes black?

1 Like

Hi Chris,
thanks for your feedback. I try to find a display with HDMI input to complete the initial setup.
No, the display remains entirely black (or better dark grey), no NVIDIA logo becomes visible.

any word on when the official image will be based on 20.04?

1 Like

Hey Jens & Chris,
Were you able to figure out a solution to your problem? I’m having the same issue and I can’t see the Green logo.
Ubuntu 18.04 image from Nvidia seems to work fine. On a revision 200 board btw.

Hi asvinp,
I followed the recommendation of Chris to finish the initial setup via HDMI. That worked as expected and afterwards I was able to use DisplayPort also.

Hey Jens,

I was connected via HDMI and wasn’t getting any response from the board.
But, it seemed to be an issue with the download of the image. Re-downloading it from Chris’s Github allowed me to boot into the user setup screen and eventually into 20.04. :)

Thanks for your reply!

Hi asvinp,

Could you provide the exact link that you downloaded the working image from? I am currently having the same issue where connecting the board to HDMI gives no response on the monitor (official image works fine). I tried what I thought was downloading the image from Chris’s Github but I had the exact same behavior as before.


Please keep in mind that this image was created for the A02 revision of the jetson nano.

If you own a B01 Revision or any other, you will most likely run into video issues.

The solution is to edit the extlinux.conf file located in the boot directory and modify the first FDT line to point to the correct .dtb for your board.



Hi Chris,

I have tried the image on both a B01 and A02 with no luck.


well that is very odd then it should work without any issues on an A02 board.

what program are you using to burn the image , try using belena etcher.

also try extracting the image through the terminal rather than the desktop.

It sounds like there is something wrong with the way the image was burned maybe.

are you making any modifications? to the image prior to attempting to boot it for the first time?