Yolo for deepstream-app

Please install rtspserver and try again.

sudo apt-get install libgstrtspserver-1.0

@DaneLLL

many thanks, it is working well!!

I just want to hook into this conversation and ask what kind of FPS you are getting with deepstream-yolo-app for yolov3 (full, non-tiny). I’ve also tried the https://github.com/AlexeyAB/darknet darknet fork which has support for Tensor Cores and Cuda Cores.

On the Jetson Xavier i’m able to get about 20FPS using AlexeyAB’s Darknet. The deepstream-yolo-app seems much slower (i’m using the same file, 720p deepstream sample stream). But I don’t know how to accurately measure it.

Because the deepstream yolo app uses all the Xavier hardware parts and is optimized to not use much CPU i figured i would be getting better results than with AlexeyAB’s code.

Any help figuring the FPS out or optimizing the deepstream app further would be much appreciated!

@steven4k,
For clearness, you may kick off a new post for your issue.

Thanks @DaneLLL, will do!

Hello, I was trying to get the patch working for the yolo plugin. But couldn’t get it to run.

** ERROR: main:565: Failed to set pipeline to PAUSED
Quitting
ERROR from src_bin_muxer: Output width not set
Debug info: gstnvstreammux.c(1616): gst_nvstreammux_change_state (): /GstPipeline:pipeline/GstBin:multi_src_bin/GstNvStreamMux:src_bin_muxer
App run failed

I’ve tried changing the sink to 1 and 2, didn’t work for either case. I’ve ensured the gpu-id =0, still didn’t work. Any help would be greatly appreciated. Thanks.

Here’s the forum question I posted.

https://devtalk.nvidia.com/default/topic/1051597/deepstream-for-tesla/error-from-src_bin_muxer-output-width-not-set/

Hi, where i can place patch file to run
thanks