YOLO has been killed on Jetson TX1

Hi,

When I tried to run YOLO v2 with yolo-voc.cfg and yolo-voc.weights on Nvida Jetson TX1 (Ubutu 16.04, JetPack-L4T-2.3.1 and nvcc 8.0), YOLO has been killed after loading layer 27. (i.e. the error message is “28 Killed”). I compiled YOLO with CUDNN=1 and OPENCV=1 on Jetson TX1. However, there is no problem on my desktop (Ubuntu 14.04, nvcc 8.0)

Any comment would be appreciated.

Perhaps you ran out of memory. You may want to run something like htop while starting YOLO, see if memory goes down.

Thank you for your comments. The problem was out of memory. When I changed batch from 64 to 1 and subdivisions from 8 to 1, there is no problem on Jetson TX1. Could you explain what is “batch” and “subdivisions” in YOLO v2?

I do not know about YOLO, someone else will have to comment. Typically such software uses multiple threads or multiple GPU kernels at once and offers to set a cap on maximum threads/kernels…this is likely what your options do is cap max threads or GPU kernels (or recursion depth).

Hi,

Batch size means the number of images algorithm process at a time, subdivisions is used to divide the total work into real GPU jobs.

For examples,
Set batch size to 64 means algorithm will update weight every 64 images.
Set subdivision to 2 means to divide the total work into 2 gpu jobs:

Gpu process 32 images each time
Algorithm update weight after two GPU jobs are done.

More images process at a time means more memory usage.

You can see my repository about YOLO darknet:

Can Yolov2 full algorithm (trained for coco data) runs on Nvidia Jetson Tk1? what’s the fps?

No.

TK1 doesn’t support cuDNNv5 which is used by YOLO.
Thanks and sorry for the inconvenience.

Hi,

I installed yolo demo from below github link and it worked with jetson TX2 onboard camera, but FPS is 2.5 maximum. How can I increase FPS? Why is FPS too low?

Thanks

You may improve fps using tiny-yolo. You may check https://devtalk.nvidia.com/default/topic/1026824/using-yolo-on-jetson-tx2-and-econ-system-cameras/