YoloV3Tiny on Xavier, DS4.0 TRT5.1.6 not working correctly

Hi,

Running DS4.0 (not the latest, has some issue upgrade the latest JetPack).
Trained YoloTinyV3 on one class using AlexeyAB repository. Works great on my Xavier when running from the command line.

Tried to convert to DeepStream using the sample provided.
Results are bad, they are not accurate AND probability for each match is lower or non existent.

I verified the following:
– Input is the same - wrote it to file before its submitted to the engine both in the TRT (DS) and the yolo.
– Known issue - I used yolo layer of (0,1,2) and not (1,2,3) in both training,conversion and inference
– used fp32, batch 1
– The output buffers are different immediately after the engine execution - its not a parsing issue.
They are different significantly, not some small accuracy issues.

Q1: Has anyone tried using YoloTinyV3 on DS, with own trained data, successfully ?
Q2: Are there any known issues in this version of DS (4.00) OR TRT (5.1.6), that might cause this behaviour ?

Thanks for the help !

Please ignore this q, I solved this issue.