Yolov5l.onnx in Deepstream 5

Please provide complete information as applicable to your setup.

**• Hardware Platform (Jetson / GPU)**Xavier
• DeepStream Version5.0
• JetPack Version (valid for Jetson only)
• TensorRT Version
• NVIDIA GPU Driver Version (valid for GPU only)
• Issue Type( questions, new requirements, bugs)
• How to reproduce the issue ? (This is for bugs. Including which sample app is using, the configuration files content, the command line used and other details for reproducing)
• Requirement details( This is for new requirement. Including the module name-for which plugin or for which sample application, the function description)

In ultralytics/yolov5, use (python models/export.py --weights yolov5l.pt --img 640 --batch 1 ) to get onnx, And with config.txt
[property]
gpu-id=0
net-scale-factor=0.0039215697906911373
model-color-format=0
onnx-file=/home/nvidia/model/yolo5/yolov5l.onnx
model-engine-file=/home/nvidia/model/yolo5/yolov5l.onnx_b8_dla1_fp16.engine.enc
labelfile-path=/home/nvidia/model/yolo5/yolov5s.txt
batch-size=8
gie-unique-id=40001
#output-blob-names=prob
process-mode=1

0=FP32, 1=INT8, 2=FP16 mode

network-mode=2
enqueue-full-batch=1
num-detected-classes=80
enable-dla=1
use-dla-core=1
interval=0
cluster-mode=2
maintain-aspect-ratio=1
output-tensor-meta=0
secondary-reinfer-interval=0
force-implicit-batch-dim=0
parse-bbox-func-name=NvDsInferParseCustomYoloV5
custom-lib-path=/opt/nvidia/deepstream/deepstream-5.0/sources/libs/nvdsinfer_customparser/libnvds_infercustomparser.so
[class-attrs-all]
pre-cluster-threshold=0.6
nms-iou-threshold=0.45
And I get some wrong labels in picture top-left


Why got those labels in top-left center

what label?

person car

is it possible you set background as personal car in your label?

There is a label in the upper right corner of the picture, which should be an inferred object, but there are no people and cars in the upper left corner.
and results is :
class_id left top
0 0 0
0 0 0
0 0 0
0 0 0
0 1 0
0 0 0
0 0 0
0 0 0
0 1 0
2 0 0
2 0 0
2 0 0
2 0 0
2 1 0
2 0 0
2 0 0
2 0 0
2 0 0
2 0 0
2 0 0
2 0 0
2 0 1
2 0 0
2 0 0
2 0 1
2 0 0
2 0 0
2 0 0
2 0 0
7 0 0
7 0 0
7 0 0
7 0 0
7 0 1
7 0 0
7 0 0
0 1 0
0 1 0
0 0 0
0 0 0
0 0 0
0 0 0
0 0 0
0 0 0
0 0 0
0 0 0
0 0 0
0 0 0
0 0 0
0 0 0
0 0 0
0 1 0
0 0 0
0 1 0
2 0 0
2 0 1
2 0 0
2 0 0
2 0 0
2 0 0
2 0 0
2 0 1
2 0 1
2 0 1
2 0 0
2 0 0
2 0 0
2 0 0
7 0 0
7 0 0
7 0 1
7 0 0
7 0 0
7 0 0
7 0 1
7 0 1
7 0 0
7 0 0
7 0 1
0 0 0
0 1 0
0 0 0
0 0 0
0 0 3
0 0 0
0 0 0
0 0 3
0 1 2
2 0 0
2 0 0
2 0 0
2 0 0
2 0 1
2 0 0
2 0 4
2 0 1
2 0 0
7 0 3
0 25 154
0 0 200
0 139 160
2 322 159
2 221 158
2 391 154
2 471 163
2 191 160
2 541 158
7 390 154
7 176 148

Sorry for delay!
I’m afraid it’s model issue.

Thanks!