yum cuda rpm broken logic (conflicts) (RHEL 6.5)

an attempt to install cuda on RHEL 6.5 (with elrepo in yum from which nvidia drivers were installed earlier)

–> Processing Dependency: xorg-x11-drv-nvidia-devel(x86-32) >= 319.00 for package: cuda-5-5-5.5-22.x86_64
–> Processing Dependency: xorg-x11-drv-nvidia-libs(x86-32) >= 319.00 for package: cuda-5-5-5.5-22.x86_64
–> Processing Dependency: xorg-x11-drv-nvidia-devel(x86-64) >= 319.00 for package: cuda-5-5-5.5-22.x86_64
–> Processing Dependency: nvidia-xconfig >= 319.00 for package: cuda-5-5-5.5-22.x86_64
–> Processing Dependency: cuda-driver >= 319.00 for package: cuda-5-5-5.5-22.x86_64
–> Processing Dependency: nvidia-settings >= 319.00 for package: cuda-5-5-5.5-22.x86_64
–> Processing Dependency: nvidia-modprobe >= 319.00 for package: cuda-5-5-5.5-22.x86_64


—> Package xorg-x11-drv-nvidia.x86_64 1:319.37-2.el6 will be installed
–> Processing Dependency: xorg-x11-drv-nvidia-libs(x86-64) = 1:319.37-2.el6 for package: 1:xorg-x11-drv-nvidia-319.37-2.el6.x86_64
—> Package xorg-x11-drv-nvidia-devel.i686 1:319.37-2.el6 will be installed
—> Package xorg-x11-drv-nvidia-devel.x86_64 1:319.37-2.el6 will be installed
—> Package xorg-x11-drv-nvidia-libs.i686 1:319.37-2.el6 will be installed
–> Running transaction check
—> Package xorg-x11-drv-nvidia-libs.x86_64 1:319.37-2.el6 will be installed
–> Processing Conflict: nvidia-x11-drv-331.38-1.el6.elrepo.x86_64 conflicts xorg-x11-drv-nvidia
–> Finished Dependency Resolution
Error: nvidia-x11-drv conflicts with 1:xorg-x11-drv-nvidia-319.37-2.el6.x86_64

I don’t suppose Nvidia’s employees intended it,
should this be reported as a bug? if yes then where?
can this conflict be resolved, I mean can Nvidia try to work with elrepo and together agree on naming conventions?

regards

Bumping this because I am currently experiencing the same issue.