zed ros wrapper on JTK1 problem?

I’ve downloaded zed ros wrapper successfully following this site:


but since I use JTK1 I skipped all before the ros section

note: I also downloaded ros indigo desktop full before following the previous website

when I run the commands :
roslaunch zed_wrapper zed.launch in terminal tap and
roslaunch zed_rtabmap.launch in another tap

the program start but it shows lines and it construct the 3d model very very slowly when I try to change some settings it suddenly closed giving me this error:

[camera/zed_wrapper_node-5] process has died [pid 7520, exit code -9, cmd /home/ubuntu/ros/indigo/devel/lib/zed_wrapper/zed_wrapper_node __name:=zed_wrapper_node __log:=/home/ubuntu/.ros/log/c9104cc8-9444-11e6-850b-f4f26d1c8979/camera-zed_wrapper_node-5.log].
log file: /home/ubuntu/.ros/log/c9104cc8-9444-11e6-850b-f4f26d1c8979/camera-zed_wrapper_node-5*.log

when I tried to run the command:
rosrun rviz rviz

it opened the program showing the grid empty when I tried to add panel to add the /point_cloud/cloud/PointCloud2 so I can see the live mapping it suddenly closed giving me this error:

[ INFO] [1476694905.957255060]: rviz version 1.11.14
[ INFO] [1476694905.957656056]: compiled against Qt version 4.8.6
[ INFO] [1476694905.957802138]: compiled against OGRE version 1.8.1 (Byatis)
[ INFO] [1476694906.580238824]: Stereo is NOT SUPPORTED
[ INFO] [1476694906.580583821]: OpenGl version: 4.4 (GLSL 4.4).

I don’t know what is wrong or what I am doing wrong can you please help me?

Yesterday I completely updated system on jetson TK1 (jetpack 2.3) on SD card including set CUDA 6.5. OpenCV 2.4.13, ROS jade and ZED for TK1 V 1.1.1. and also set and checked in operation of zed-ros-wrapper. No what problems with operability of JETSON or ROS were. ZED shows about 18 frames per second.
There are several nuances on the jade setup for operation with OpenCV for tegra. The problem is that jade uses references to OpenCV 2.4.8. And with jetpack OpenCV 2.4.13 is set. both in case of compilation and in case of a programs runtime there can be errors or incorrect operation, for correction I used the instruction on http://myzharbot.robot-home.it/blog/software/ros-nvidia-jetson-tx1-jetson-tk1-opencv-ultimate-guide/. (for TX1 with kinetic this step isn’t required everything any more earned without modifications). Perhaps you inattentively read the instruction for ZED in which need to set ZED SDK (to overload jetson) then it is necessary to launch ZED Exploer is specified - the program will make the ZED setup of the camera for operation in system and only then it is possible to launch the camera in ROS. For incorrect operation of rviz the IC needs to use recommendations (http://wiki.ros.org/indigo/Installation/UbuntuARM) -
Insert in ~ / .bashrc:
unset GTK_IM_MODULE
it is also necessary to set up the SWAP file - otherwise in case of compilation of zed-ros-wrapper there can be problems because of shortage of a random access memory the link for setup - http://www.jetsonhacks.com/2014/10/04/creating-swapfile-ubuntu-nvidia-jetson-tk1/