Zfs-dkms fails on Jetpack 5.1.2

Is there a solution or possible workaround for this?

We has the same issue as the above linked topic described.



Have you tried this in the aforementioned post?

Work around :

1) Download public_sources.tbz2 on https://developer.nvidia.com/embedded/jetson-linux-archive
2) Unzip kernel sources
3) Inside /lib/modules/"$(uname -r)" folder set the symbolic link to new kernel source folder
4) Inside kernel source folder 
	zcat /proc/config.gz | sudo tee YOUR_PATH_TO_KERNEL_SOURCES/.config >/dev/null
	sudo make -C /lib/modules/"$(uname -r)"/build modules_prepare

Hello locki.janos.m,

I created the original post and unfortunately there was no real solution. There are two options that worked for us:

  1. Manually downloading and replacing the kernel sources as described in the original post and as quoted by DaveYYY above.
  2. Do not use DKMS, but build the kernel module manually. This way it works without manually downloading the sources.

We didn’t investigate further because we can’t spend our time on something that is part of a properly running system and should be supplied by NVIDIA.