2022.1.1 Can't build TensorRT

Having same problems as https://forums.developer.nvidia.com/t/audio2face-tensorflowrt-fails-to-compile/231592. I can’t build past 10%. I’ve attached the complete log file (error at bottom).

Windows 11, 4090, 128mb ram, recommended Studio drivers.

kit_20230120_153045.log (602.6 KB)

Interestingly enough, on 2022.2.0 beta, I can build TensorRT, but I have a ton of errors rendering any graphics.

The first few errors (there are > 100) in 2022.2.0 beta look something like this:

2023-01-20 20:39:02 [Error] [gpu.foundation.plugin] CUDA processor count (1) does not match graphics processor count (2)
2023-01-20 20:39:09 [Error] [gpu.foundation.plugin] Cannot load shader file ‘rtx/scenedb/SparseMemCopy.compute.hlsl’.
2023-01-20 20:39:09 [Error] [gpu.foundation.plugin] buildShaderAsync() failed: rtx/scenedb/SparseMemCopy.compute.hlsl
2023-01-20 20:39:09 [Error] [gpu.foundation.plugin] PsoCompute::createPipeline and shader loading failed. RtxResult: 3
2023-01-20 20:39:09 [Error] [gpu.foundation.plugin] Cannot load shader file ‘rtx/utils/PrefixScanBuffer.compute.hlsl’.

Hey Rob,
As mentioned in the thread you linked, ADA generation (4090) card support begins with Audio2Face 2022.1.2

Can you attach your log file for 2022.2 instead?

kit_20230120_155011.log (673.0 KB)

Here’s the 2022.2.0 error log where TensorRT works but tons of errors on graphics side. Also, I don’t see 2022.1.2 available for download from inside the Omniverse launcher, is that right?

Thanks for the logs, I’ll send them to engineering to see whats up.

For 2022.1.2, it’s there but just a bit hidden. We are cleaning up old builds so its clear everything appears as beta.
You should be able to find it by looking under the Beta dropdown, then select the version drop down (where it says 2022.2.0), Select “All Beta Builds”, and it should be there.

1 Like

From the log, it looks like you have 2 graphic cards active.
Can you try disable the other non RTX card and see if it would run?

| Driver Version: 527.56        | Graphics API: D3D12
|=============================================================================================|
| GPU | Name                             | Active | LDA | GPU Memory | Vendor-ID | LUID       |
|     |                                  |        |     |            | Device-ID | UUID       |
|---------------------------------------------------------------------------------------------|
| 0   | NVIDIA GeForce RTX 4090          | Yes: 0 |     | 24156   MB | 10de      | c75c4d00.. |
|     |                                  |        |     |            | 2684      | 0          |
|---------------------------------------------------------------------------------------------|
| 1   | AMD Radeon(TM) Graphics          | Yes: 1 |     | 485     MB | 1002      | 147f2000.. |
|     |                                  |        |     |            | 164e      | 0          |

I will give that a try over the weekend and reply back here with my findings. Thank you y’all for stepping in so quick to offer up help.

Running audio2face.kit.bat --/renderer/multiGpu/maxGpuCount=1 --/renderer/multiGpu/activeGpus=0 should solve the issue if you don’t want to disable AMD.