260.19.06 32-bit Linux driver: CL_OUT_OF_RESOURCES on clCreateContext on code which ran fine with 19

Hey guys, here’s an interesting one. I decided to revisit my OpenCL projects after letting them gather dust for a while, and found that they no longer worked (even to the extent that they worked before.) So I went back to some example code I used when I was first starting out with OCL, and that didn’t work anymore either. The main difference is that I have upgraded to the 260.19.06 driver. I tried reinstalling the driver, no dice. I even booted into the kernel I was using back then, just in case it would help (it didn’t.)

I have isolated the problem as far as clCreateContext, which is returning NULL and setting err to CL_OUT_OF_RESOURCES. All previous OpenCL function calls are returning CL_SUCCESS. Interestingly, CL_OUT_OF_RESOURCES isn’t even one of the errors that clCreateContext is allowed to return, according to the OpenCL spec. The same error is popping up in C/C++ code and in PyOpenCL.

I have been able to reliably duplicate the bug with some open-source example code which is available here:
https://github.com/enjalot/adventures_in_opencl
The C++ example apps fail, as do the Python ones.

This is with the 260.19.06 32-bit Linux drivers (nvidia-current package from Ubuntu 10.10.) Tested with kernels 2.6.35 and 2.6.33.