A scale bug was introduced when you updated to Kit 105

Someone from NVidia, possibly Richard (sorry, that is all I remember of his name) mentioned this is a known issue. I am just posting this so I get notified or to make sure this is getting fixed.

Prior to the latest Composer update, files from Blender or even Nvidia Assets all seemed to be the right scale. Now I get this message on almost every asset.

You can’t see it in this picture, but the Billiard table was brought in from NVidia Asset’s tab. You have to increase the scale from 1 to 100 for X, Y and Z to be able to see it.

Mismatched Units found on drag and drop, resolved in current Authoring Layer path: World/BilliardTable.

This scale also makes the Reallusion connector not work, as IClone cannot handle super large files. If this is a known issue, is there any timeline for a fix?


@DataJuggler, with Composer 2023.1+ , there are extensions that are enabled by default. the specific extension that’s giving you the mismatched units prompt is the Metric Assembler, and the prompt is simply indicating that the source and destination USD has different scene scale.

in other words, the payload will automatically be scaled accordingly with the help of this new extension, which is what you probably want as the source USD could come with different unit of measurements. that said, you can always use the measure tool to confirm the actual scale of the asset in your destination scene; it could be that the checkered grid is too large instead of the payload being too small. the video does a pretty good job explaining what’s happening under the hood. in addition, there are preferences in which you can set the default meters per unit setting on a new stage.

i believe the “BilliardTable.usd” was set to cm (notice the layer’s MPU is set to 0.01). so it’s likely your scene is set up as meters.

Is it possible to set the Default unit? I saw you have some files setup for Meters, CM, inches, etc., how do you do that? I just tried changing the unit in the Layer Root. Meters to Units, and the lower left corner didn’t change.

I will experiment with this some more, I am sure I just know how to use this yet.

Thank you for the explanation.


the default behavior should be akin to the following (reflect in the USD):


p.s. note that this is in the source BilliardTable.usd

the default unit of the USD is determined by the preference setting. and based on my experience, this seems to apply to new scenes created after the fact (File > New or creating the USD via right clicking in the content browser). once you’ve created the new USD scene, you should be able to verify the unit reflected in the layer property.

Thank you, now I understand. Is there a way to set the default for new projects?

yea, should be in preferences as i mentioned (sorry it was done in an edit, so you probably want to refresh the page to see it). also worth noting that this setting is stickied between your sessions; so if you have the need to change it for one asset or specific use case, you will want to change it back after.

1 Like

Hi DataJuggler,
Let me know if you have any further questions on scale.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.