Anyway to completely disable randr support?

I tried xorg server flags to disable randr…

Basically using the nvidiaXineramaInfoOverride or NoTwinViewXineramaInfo works for the desktop stuff but I found on newer versions of drivers certain things/window mangers are still multi-screen aware. For example playing a full screen video only goes over half the screen (as I am driving a single 4k monitor over multiple inputs).

For now I am running old (295.53) drivers which seem to work as expected due to lack of newer randr support but this isn’t going to fly forever…

So is there some way to completely disable randr or fake randr information like you fake xinerama info currently?

They’re talking over a long-term solution:

Ah thanks for that link. Yeah for now I am just sticking to older drivers without RandR 1.2 support. I have used 4k tiled displays since 2006 (I lol’d a little bit when the first sentence says starting to make…)

Anyway older drivers always handled this with absolutely no problems. Also my main machine is still using an old X (with XGL) which pre randr 1.2 so I have not had any problems until recently when I was getting a machine setup for my sister and installed a new ubuntu for her to use and then boom the problem cropped up…

I honestly think I just opt for the number 1 option. Maybe I will sign up that mailing list as I am on several other including the linux kernel one.

Of course randr doesn’t give me any functionality I care about. In general it seems to make X windows more like windows with plug and plan and stuff like that which is actually the wrong direction to go in IMHO.

Linux by far seems to be the best OS for driving these displays being able to setup everything through config files and even get scaling at lower resolutions working correctly by you telling X what to do. I had people argue with me on other forums saying you can’t do scaling over MST and I said no… they just haven’t implemented it to the point that I made a youtube video showing it:

Just thought I would also Mention I had to disable kdm and use xdm instead as kdm was crashing anytime I used notwinviewxineramainfo or the twinviewxineramainfooverride.