Apt-get update failure in Ubuntu 20.04

Followed instructions here: CUDA Toolkit 11.4 Update 1 Downloads | NVIDIA Developer to install cuda, but get the following error:


Err:26 Index of /compute/cuda/repos/ubuntu2004/x86_64 Packages
404 Not Found [IP: 152.195.19.142 443]
Fetched 2,220 kB in 3s (754 kB/s)
Reading package lists… Done
E: Failed to fetch https://developer.download.nvidia.com/compute/cuda/repos/ubuntu2004/x86_64/by-hash/SHA256/751939d95516afc289908a19e447f0acc1506367f72ed356431a2b1a469cc8ca 404 Not Found [IP: 152.195.19.142 443]
E: Some index files failed to download. They have been ignored, or old ones used instead.

I have been trying this since 4 days ago. Keep getting the same error. Is this a problem with the repo?

Thanks.

1 Like

Hi,
We get the same problem using ANSIBLE deployment.
Here is the part of the ANSIBLE script, the Add Nvidia CUDA APT Repository task being the one failing like @sjayewar .

- name: Download Nvidia CUDA PIN Priority File
  get_url:
    url: https://developer.download.nvidia.com/compute/cuda/repos/ubuntu2004/x86_64/cuda-ubuntu2004.pin
    dest: /etc/apt/preferences.d/cuda-repository-pin-600

- name: Add Nvidia CUDA APT Public Key
  apt_key:
    url: https://developer.download.nvidia.com/compute/cuda/repos/ubuntu2004/x86_64/7fa2af80.pub
    state: present

- name: Add Nvidia CUDA APT Repository
  apt_repository:
    repo: deb http://developer.download.nvidia.com/compute/cuda/repos/ubuntu2004/x86_64/ /
    state: present

- name: Install Nvidia CUDA Driver
  apt:
    name: cuda-drivers
    state: latest
    update_cache: yes

When looking at the Release file on the repo URL, the 751939d9... SHA256 hash is not present in the Package file. That might be the problem.

The odd is I tried with a fresh install Ubuntu 20.04 on a VM, and it didn’t had trouble getting the repo and packages. Maybe the apt configuration is different ?

+1

Getting a 404 as well, same package hash. Repo is currently unusable.

Same here, our rendering servers cannot be updated anymore. Anyone here fom Nvidia who can help us out?

Hello, same issue for me on 20.04 but it works properly for 18.04

Encountering here as well. Sounds like Nvidia’s apt repo for 20.04 has been broken for a few days?

Someone opened an issue on Github ansible-role-nvidia-driver
ansible-role-nvidia-driver
but no answer at this time.

Okay we got a fix for our problem: We HAVE to set the repo URL to HTTPS to work, I don’t really understand, but well, it resolved our problem.

1 Like

Looks like someone figured it out too for the ANSIBLE role: Fix repository base url of Ubuntu. by ohsawa0515 · Pull Request #42 · NVIDIA/ansible-role-nvidia-driver · GitHu

I confirm it solves the issue for me too ! thanks for sharing this information