Booting Issue on Jetson Nano When Using UART pins on J50

I am currently facing an issue with my Jetson Nano (module: P3450-180-13449-DAAF-B01). I am using the pins 3 and 4 (UART RXD and UART TXD) on J50 to communicate with other components.

However, I encounter a problem during the boot process when the other components are powered on. The Nvidia logo gets stuck on the screen.

Is there a method to ensure a smooth boot process for the Jetson Nano while UART communication is active on J50 and the other components are powered on?

Hi tbal21,

Are you using the devkit or custom board for Jetson Nano?
What’s your Jetpack version in use?

Do you mean if you hit the boot issue after using pin3 and pin4 on J50?
Could you boot as expected w/o any UART connection?

Please share the full serial console log for further check.

Boot process is successfull when I do not use UART connection.
Everything functions correctly when I utilize pin3 and pin4 AFTER the booting process completes successfully.

Yes, the booting issue occurs when I use pin3 and pin4 on J50.

It is Jetson Nano DevKit.

How can I check the log file ?

I found these 2 pins are the one used for debug.

What’s your use case for this UART?

Please refer to the following instruction to capture serial console log.
Jetson Nano & NX Style - Serial Debug Console - JetsonHacks

I want to read a sensor data using the UART pins that I mentioned. But these pins are also used for the debugging console during the booting process.

It seems that disabling the debug console during the initial boot might be necessary for successful booting. Am I right?

To adress this issue, I followed the steps outlined in the following forum post:

I edited the p3448.conf.common file as instructed and flashed the SD card accordingly.

After that I tried to convert “/dev/ttyTHS1” and “/dev/ttyS0” to dialout.
However, I was only able to convert “/dev/ttyTHS1” to dialout.
“/dev/ttyS0” still remains as tty. Do you have any suggestions?

Correct, but we don’t suggest for this use case and we don’t verify this.

Have you tried using UART1(PIN8, PIN10) from J41(40-Pin Expansion Header) to read the sensor data?

Yes, I am already using the UART pins on J41 for another sensor. That’s why I need to use the UART pins on J50.

There should be a solution to boot the Jetson Nano while having a sensor connected to the UART pins on J50.

Thank you for your assistance.

Since the combined UART is coming from different boot stage so that it should be disabled from different firmware.

There’s another UART from M.2 Key E, you could also use it.

Thank you for your suggestion but I am also using M.2 Key E connector:)

There is no update from you for a period, assuming this is not an issue any more.
Hence we are closing this topic. If need further support, please open a new one.

Sorry that there’s only 3 UART interface on Jetson Nano devkit.
Have you also tried using TTL cable from USB port for your sensor?