Cannot change uefi boot logo

HI, all
I follow the link below to build a custom UEFI image. and replace the BOOTAA64.efi and uefi_jetson.bin files in bootloader directory so how can I flash the new UEFI image into orin agx? and what’s the detailed instructions?

You can try to do full flash and it shall be updated.

yes,it may help,but i mean if there are a single cmd to flash only uefi, so it can save time。。。

“-r” can skip the generation of system.img.

“-k partition_name” can flash the partition only.

And you can check the partition name in those xml files under your Linux_for_Tegra/bootloader.

These didn’t change between rel-32 and rel-34.

ok,thx @WayneWWW

I follow your suggestion and it success to flash the new uefi but there‘s some thing wrong with uefi pictures.

so let list the progress.

I wanna to replace the uefi picture, so I follow the instructions as below:

then I rebuid the uefi source code according to the instruction: Home · NVIDIA/edk2-nvidia Wiki · GitHub

next I got BOOTAA64.efi and uefi_jetson.bin files and replace the file in bootloader directory.

finally I flash the whole image as you mention above.

after reboot I didn’t get the expected picture and it’s just black!

so if there is some thing wrong with my method, and any suggestion? thank you!

Let me try it on my side.

Also, is it okay to change this topic to “cannot change boot logo”? This will be more specific to your topic.

hi @WayneWWW ,is there any update about this topic? waiting for your reply~

Hi, I have the same problem, I cannot change the logo Flashing error after uefi boot logo changed for Jetson AGX Orin

this pic may helpful for this issus

Hi @mmcly when you use sudo ./ -r -k <partition_name> jetson-agx-orin-devkit mmcblk0p1 what name did you use?
I see from Linux_for_Tegra/bootloader/t186ref/cfg/flash_t234_qspi_sdmmc.xml several list of Jetson AGX ORIN partitions. Should it be A_cpu-bootloader or B_cpu-bootloader associated to TBCDTB-FILE the partition we have to update?
I notice from Partition Configuration — Jetson Linux<br/>Developer Guide 34.1 documentation that TBCFILE associated to uefi_jetson.bin is missing on flash_t234_qspi_sdmmc.xml

infact, i didn’t use a single part to flash, I just follow @WayneWWW suggestion to use a full flash…

but what you said, I think is right, so maybe this a bug in jetpack5.0DP, right?


Please pick the patch from here to your UEFI source and try again.

Hi @WayneWWW I applied your patch. And then I updated $HOME/Linux_for_Tegra/bootloader/uefi_jetson.bin after building the new patched firmaware. And finally I only flash the uefi firmware by executing sudo ./ -k A_cpu-bootloader jetson-agx-orin-devkit mmcblk0p1. Still the logo does not show up after powering up the system. Screen still black like Cannot change uefi boot logo - #6 by mmcly
Is it the way to flash the firmware? Can you confirm what I did wrong while flashing the system. Thank you

The patch is for the error reported by mmcl1. Please check your uart log whether that error is still or not.

I apply patch fix: t234: clean invalidate caches to scf level using mce ari by ashishsingha · Pull Request #6 · NVIDIA/edk2-nvidia · GitHub but still get error below at boot time

And I notice that fix which displays USB on UEFI boot Support for UEFI USB on Orin by jbrasen · Pull Request #1 · NVIDIA/edk2-nvidia · GitHub no longer worked after applying fix: t234: clean invalidate caches to scf level using mce ari

Hello, which tools do you use to generate/convert your bmp file to comply Orin system logo requirement (bmp.blob)?

Hello @WayneWWW @mmcly I was able to update boot logo. To do that I use mspaint to resize bmp images and comply 640x480, 1280x720 and 1920x1080 format. And then I only update Linux_for_Tegra/bootloader/uefi_jetson.bin and then flash the Jetson firmware by performing sudo ./ -k A_cpu-bootloader jetson-agx-orin-devkit mmcblk0p1
Note that when using gimp to scale images, boot logo does not work. We can notice a slice difference in size between mspaint tools and gimp resizing output.

1 Like

Thanks for sharing. I will try to make this noted over some document.

Could you share the summary so far? Did you also apply the patch?

I do not apply the patch
I download and extract L4T BSP, Sample Root Filesystem and UEFI Sources
I setup bmp images supported size
I update logo and build UEFI firmware
I update Linux_for_Tegra/bootloader/ uefi_jetson.bin
I flash only the A_cpu-bootloader partition
Finally after booting system logo changed.
The only issue is to define correctly supported image size with appropriate tools

Ok, so you didn’t hit the same error as mmcly ?