Cannot install the official driver on a Skylake / 2xTitan X / Debian 8 platform

Hi,

We currently are building a small computing farm to enhance our CUDA-based solution with better performance.

We have two computers with the following hardware :

  • Asus Z170-A
  • Intel Core i7-6700K
  • 2 x 8 GB DDR4 Kingston 2400 Mhz (total -> 16 GB)
  • Gigabyte GTX Titan X 12 GB

The installation of Debian 8 works fine, and I have a display, despite of the bad resolution (1024x768 instead of 1920x1080).
I downloaded the last available and official driver from the Nvidia Downloads page, selecting the Desktop Graphics, 900 Series, Titan X GPU and Linux 64 bits operating system.

This .run file must be executed without any X server running, so I tried several ways to run Debian without X :

  • Chosing "Recovery mode" from the Debian optional menu entries in GRUB 2 : Booting stucks.
  • Pressing Ctrl + Alt + F1:6 while on the login screen : I got a blank black screen, no cursor, no text, if I press Ctrl + Alt + F7 I can go back to the login screen.
  • Choosing to run a different runlevel by adding the chosen level to the GRUB command, pressing E, editing the line and pressing F10 to boot : no effect, it always boot with graphical login screen

I tried this with a GNOME + GDM3 install, and a KDE + KDM install, from the Debian 8 CD1 iso moved onto a USB drive thanks to UNetbootIn.
All my tries were made on a fresh install. If I boot, I have graphics and can’t achieve to get a text mode login to kill X and install the driver. If I don’t install or boot without graphics, I got stuck at boot.

Could you please help me getting these two Titan X work perfectly and with the proprietary driver ?

Thanks by advance

So adding to that kernel line in GRUB: “init 3” or “systemd.unit=multi-user.target” yields X too?

What does (as root): systemctl isolate multi-user.target do now?

Try installing the debian packaged driver for it.

add-apt-repository ppa:graphics-drivers/ppa
apt-get update
apt-get install whateverversionyouwant

Or direct download here:

https://launchpad.net/~graphics-drivers/+archive/ubuntu/ppa/+packages

I’m not sure why booting into a command prompt is such a pain in the ahole with these new distributions.
Used to be just typing linux single or changing the /etc/inittab default to 3 instead of 5. Maybe it’s the same now. I dunno.
I use Linux Mint, which is Ubuntu, which is Debian that isn’t a perpetual PITA. Same distros, different pain threshold.

Btw, you don’t need to init 3 or disable nouveau(driver) if you install those packaged ones. It does it for you.

PS- I recommend 352.79. 361.28 is broke dk dogsht, as you can read from the forums.

PPS- If you are wondering why Nvidia’s drivers have the installer of a Downs baby chasing a car, it’s been that way since they started. They will never package their drivers. Why? Let’s ask Linus Torvalds.

Nope, let’s ask Linus again:
https://youtu.be/1Mg5_gxNXTo?t=6m1s

I tried an install of Fedora 23 (Live Workstation Gnome x86_64) annd followed the instructions related to Fedora to install the drivers.

I achieved to get a console at login, rather than this blank screen with Debian, and to have them installed correctly. Installation of CUDA with the RPM and instructions from Nvidia’s website worked fine too.

I am going to retry with Debian 8.3 on another computer with exactly same hardware, to see if I achieve something. I will get back with some feedback then.

Thanks.

About Nvidia and Linus Torvalds, I already know what have been done or said between them, it can be funny the first time but by now it is not helpful at all.

So, I installed Debian 8.3 from the 8.3 Gnome Live image (a lot bigger than the CD1, which seems to be netinstall only and require network at each installation).

I installed the distrib before doing anything related to newtork (LAN).

After installation the system seems to work fine, despite of the fact it’s the open driver “nouveau” seems to allow the optimal size in pixels for my screen (1920x1080).
Networking on the LAN chip (Intel i219v) is fine and “plug’n’play” friendly.

I downloaded the last driver from Nvidia’s website with the same parameters as usual : Desktop graphics, GTX 900, Titan X, Linux 64 Bits.

I opened a terminal and did this as root to ensure I have the good headers :
apt-get install linux-headers-$(uname -r)
It seemed that they were already there.

Next, I switched to the console login by pressing Ctrl Alt F1 and logged in.
As root, I tried to install the drivers like this :
cd /path/to/the/driver/folder
chmod u+x ./DriverFile.run
./DriverFile.run

But, during the extraction, after a few lines of “.” printed to screen, I saw a “Extraction failed” error from the .run file. It stopped the installation, due to the error.
I have no more info about this error from the installer. Maybe is there a log file or a report I could open ? I’m impressed that we still got software that catchs and treats error but don’t print them to the screen.

Installation log is stored at /var/log/nvidia-installer.log or some similar name.

Thanks. I will look for this log if I get back on the involved computer.
I got new priorities due to the hard challenge to get these @#&%$ graphics cards working…

please share nvidia bug report with detail info about issue you are observing now.