Cannot start Omniverse View/Create

I cannot start View nor Create from the launcher;

  • View: Disappears few seconds after the window frame starts to load, then only the splash screen image persists forever until I manually close it from the Task bar.
  • Create: Crashes after UI appears.

Any suggestion?
Thanks.

omni.view.app.splash
kit_20201218_143600.log (80.0 KB)
Create\2020.3
kit_20201218_135006.log (140.8 KB)

Looks like it might be crashing as it sees your intel GPU as a second GPU.

Can you got to the launcher, find the app you want to run, go to settings
image

then find the path the app is in.

Once you find that path, please run the omni.create.singlegpu.bat

If that works, once the app is up, go to help, app launcher and set the default app to SingleGPU

It worked for Create, thank you.
Also, it seems like new 2020.3.1 version is working fine without changing the app launcher default to single gpu.

Is there anything I can do to fix Omniverse View, too?

In view, you can run this bat file image

I believe the one above it, the MGPU is the default. There is no app configurator for View yet. but you can edit the bat file and remove the mgpu part

It doesn’t seem to solve the problem…maybe other error?
Could you look into the log file I uploaded earlier? It isn’t from log folder for View(no log file in this folder) but from omni.view.app.splash folder.
Thank you.

Sorry that you are having issues with View. Can you upload the following file

C:/Users/[Your User]/AppData/Local/ov/data/Kit/View/101.1/omniverse-kit.log

Thanks. Here it is.
omniverse-kit.log (153.0 KB)

Thanks for the log file. You have a supported driver version and GPU hardware. The problem in View that you are experiencing has been raised to development and is under investigation. At the moment there is no workaround that you can apply.

OK, thank you. At least Create is working so I can play around with it for now :)

hello,
i am the same problem with Omniverse View omniverse-kit.log (87.5 KB)

thank you

I’m having the same problem as above. Create crashes after UI loads and View never gets beyond the splash screen. I’ve tried the singlegpu.bat and there was no change.
omniverse-kit.log (244.0 KB)

Hi Giovanni, based on your log, CUDA is failing with “no CUDA-capable device is detected”.
It seems you might have a broken driver installation.
Do you have a CUDA driver installed on top of your Quadro display driver?

I recommend you to uninstall your CUDA driver and re-install your Quadro driver (Make sure to tick “clean install”).
Hope this resolves your issue.

For me, current version of View fixed half of the problem I originally had. It works fine only when opened from the launcher.
“Send to View” (in my case, from Revit) still has the same problem of not going beyond its splash screen.
But, I found that “Send to View” still does create the USD file structure of the project under my Omniverse user folder. So if I open View first from the launcher and navigate to the file, I can use View with the file.