Cannot turn on my TX1

Hello everyone, today when I try to turn on my TX1, I pressed the power switch normally, but the green lights were not on as usual. The red light(CR5) is on all the time. Anybody know how to fix this? Thank you a lot!

It may be actual hardware failure, but I’d suggest removing power, holding the power button down about 5 seconds, then letting it sit for a few hours…followed by plugging it back in and trying again (give it time for the supercap to discharge).

EDIT: One thing I forgot…make sure to remove anything connected which isn’t needed, e.g., you might remove all USB devices or PCIe devices prior to powering up. A keyboard, mouse, or HUB could be connected after boot if it succeeds.

Thank you a lot for your suggestions, I have tried these steps yesterday without connecting any other devices, but I am still not able to turn it on. Anything else I should try?

It looks like the unit has power since the main power LED shows, yet it is unable to start. Other than re-seating the module as a test (and I’m not sure if that would void any warranty) it may be time to RMA. If interested the RMA information is near the top of this:
https://devtalk.nvidia.com/default/topic/793798/embedded-systems/some-jetson-web-links/

Thank you so much! I will contact with customer service. Thank you again for your help!