Cannot update ConnectX-7 firmware: Burning encrypted image on non-encrypted device is not allowed

I’ve recently got a ConnectX-7 card from ebay (used), however it comes with extremely old firmware and misbehaves under load (I’m using Cisco trex to generate small packet load and on rx, it shows about 60Mpps on a port 1 and something like 2kpps on port 2 and a lot of drops).

Firmware information:

# mstflint -d "${PCI_ID}" query full

Image type:            FS4
FW Version:            28.33.0751
FW Release Date:       21.3.2022
Part Number:           MCX713106AC-VEA_Ax
Description:           NVIDIA ConnectX-7 Ethernet adapter card; 200 GbE; Dual-port QSFP; PCIe 5.0 x16; Crypto and Secure Boot
Product Version:       28.33.0751
Description:           UID                GuidsNumber
Base GUID:             00000000000bbb11        8
Base MAC:              0000000bbb11            8
Image VSD:             N/A
Device VSD:            N/A
PSID:                  MT_0000000841
Security Attributes:   N/A
Default Update Method: fw_ctrl
Life cycle:            PRODUCTION
Secure Boot Capable:   Disabled
Encryption:            Disabled

I’ve tried to update firmware, but all firmwares currently available are encrypted so I’m getting following error message:

# flint -d "${PCI_ID}" -i ${FW} burn
-E- Burning encrypted image on non-encrypted device is not allowed.

Same for mlxupd - it detects that newer firmware is available, but cannot update it because of encryption.

I’ve tried sending an email to enterprisesupport, but they require a paid subscription. I’ve tried also to send an email to network-support, but they are just an alias to enterprisesupport.

Is there a way to:

  1. Encrypt the device, so it will become compatible with updates?
  2. If that is not possible, how I can get newer firmware that is compatible with current device’s state?

P.S. I don’t care about crypto functionality if that matters.