Can't find Jetson Nano on Windows 10 Device Manager

I am having trouble finding Jetson Nano on Windows 10 Device Manager.

I have followed the instructions on running the first boot, which I performed with the display.
Then, I wanted to try working with the jetson nano in headless mode, but I could not find it over USB connection.

It seems that it doesn’t appear on my macbook either? I doubt it’s a problem with my cable because it has worked for another embedded device.

Is there a way to fix this?

hi @user18827

Can you try with different USB cable.
Can you let us know whether Jetson Nano is booting up while you are on display?

Thank you

Can you also attempt to use serial console on the Nano to see if the system is actually up and running? If it is, then you’d want to include the log from “dmesg” to attach to the forum, along with the output of commands "ifconfig’ and “route” on the Nano.

I would have to agree with @ankithsingh to also try a different cable if it isn’t one supplied by NVIDIA. I say this because very few charger cables have the quality to sustain USB2 speeds, and even though they may work with other devices, about 2/3 of the “charger” cables don’t actually work on data at USB2 speeds.

So I tried to run the Jetson Nano on display and the HDMI port doesn’t seem to be working either. This previously worked on my very first boot. If I can’t run headless or on display, how do I run commands on the Nano?

Another thing to note is that the green LED is always on when I connect my Jetson Nano with power bank that provides 5V 2A (barrel jack) or microUSB, but when I connect my keyboard or mouse, the peripherals are not on/powered. Could it be a problem with my SD card? It’s just odd because everything was fine the first boot.

My issue is very similar to the ticket here: Jetson Nano Does Not Boot / Keyboard, Mouse and Monitor's LEDs off. I tried using another sd card, still didn’t work.

People usually use ssh or serial console for login when there is no monitor. If there is a monitor, but the GUI itself is the only problem, then you should be able to use the keybinding “CTRL-ALT-F2” to reach a text-only terminal on the monitor (GUI and text are different drivers).

The green light should go on and stay on. Not having peripherals power up could be due to a number of different possibilities. Do note that a 2A supply is somewhat minimal, and would be a problem if the computing load goes up, but I doubt a keyboard or mouse would care (keyboard and mouse don’t consume much power).

If the SD card content is the wrong version for the QSPI content, then you either have to flash the Nano to the version compatible with the SD card, or flash the SD card to a version compatible with the QSPI content. The Nano models using the SD card do not put the boot content on the SD card. Earlier releases put differing amounts of content into QSPI memory (which is on the Nano module) during flash, and the earlier QSPI content is not compatible with newer SD card images.

Your best bet is to flash the Nano itself with the release version which produced the SD card image. This is how you are guaranteed that the two match. Flashing is the only way one would update QSPI content.

How would I flash the Nano itself? I feel like that would require a connection between the host PC and the jetson, which I can’t do because none of the ports seem to be working.

A ubuntu host 18.04 on x64 machine is required.

Would a VM be sufficient? If so, how much memory and storage should I give it?

No, VM is not supported.

So since I only have a Windows 10 PC, do I have no other options but to return my Jetson Nano for another?

Actually, most of the development and debug tools for jetson are based on Linux machine.

If you don’t have one and you hit an error, my only suggestion is find a ubuntu host machine.

I don’t really know what you mean by “ubuntu host machine” and how that’s different from running a VM with ubuntu. I’m pretty frustrated with all the issues I’ve been having with the jetson nano. I have no clue why it’s not working ever since the first boot. Unless there’s a step by step solution for me to fix this issue, I think it may be best for me to swap out my jetson nano.

Let me clarify more:

  1. Since this is embedded device, so usually we use a x64 host machine to debug any error if the arm64 device (jetson nano) gets any trouble. We suggest to use ubuntu 18.04 as this host machine. Most of our debug tool is based on ubuntu. We don’t actually test much on Windows.

  2. There is a method to reflash the whole jetson nano board. And this method is different from sdcard image. The reason why such re-flash is needed is mentioned by @linuxdev 's comment.
    Most easiest way to do such full reflash is using the sdkmanager tool. But this re-flash is not able to work well on VM. So when I said VM is not able to work, what I am talking about is for this tool.

What I don’t understand is how can I use ubuntu 18.04 as a host machine when I can’t use a VM or own a Linux device? In other words, is there a way to do such using a Windows 10 device? If not, I don’t see how I can resolve my issues.

I appreciate you keeping up with my issue. It’s just that I may have a gap of understanding.

Maybe install dual system on your machine.

You can also search some posts on this forum for running sdkm over VM. There are some users sharing their “tricks” to let sdkm able to work well on VM.

However, I cannot guarantee that would 100% work or not. Maybe just another time wasting on your side.

So after dual-booting ubuntu, do I follow the instructions to download and install nvidia sdk manager?
Also, is ubuntu 20.04 also supported?

Ubuntu 20.04 is not supported yet. So using 18.04 is better.

I have to firstly warn you that we cannot guarantee whether this is hardware problem or not. If this is hardware problem, then even sdkmanager cannot resolve the issue.

The most common method to debug an issue is

  1. reflash the board with sdkamanger. So we can make sure the software is clean.
  2. Follow below method to dump the log if we still have issue after sdkm flash. We can use the log to tell what is going on
    Jetson Nano Style - Serial Console - JetsonHacks