CC is characters are finally Realtime!

Hello, exciting news! I got a tip from Benjamin Samar about using the Path Traced skin material in RTX realtime mode. It works finally and thank you very much Benjamin!

See, this is my final realtime result:

However, it did not came easy.
Rabbit Don’t Come Easy ( Helloween working music) !!

The orginal native RTX shared looked like this:

Here is the combination of all renders, you can see how the “Path Traced skin material in RTX realtime mode” solution kinda loose all the details of the skin:

How can we get the details back?

My solution was to combine in post the both realtime renders, and also added a skintone correction adjustment layer. This can easily be done by everyone and also possible to do at cloud ( we are building our Cineshare product at Infinite-Compute, they are our partner ).

I had a 60% transparency on the top layer ( sss shader hack )

So please join the conversation, what do you think of this?


@weienchen @WendyGram @eetatwei @DavidDPD

1 Like

There are so many variables at play here that it’s hard to know where to start, but I will share for the moment my attempts to maximize Camilla skin shaders generated via iclone path trace export, albiet brought into rtx mode w sss enabled. I agree that for sure, once the path trace prepared skin shaders are brought into rtx mode, there is a washing away of certain details. I will also submit though that I believe these normals and micro-normals details are still there, even upon leaving default settings as is, they just become more sensitive to the scenes lighting conditions, rendering settings, and settle latency. You can as an option crank up the normals and micro-normals settings a bit, but I’m not sure if that is the key here.

There are other factors as well when it comes to taming and getting the most from the rt mode inside of composer. This will likely impact the performance level regarding fps, but if it is our goal to get the best possible quality result, I would suggest some of the following strategies.

Eco mode disabled.

I went to ‘rendering settings’ (by clicking on the rendering engine selection menu in the viewport) and selected ‘load from preset’ —> final

Set the super resolution mode from DLSS to DLAA. (yes this will impact vram so be advised, honestly I dont know how critical this is but I just wanted to remove this as a factor)

I believe it’s important to disable the ‘experimental’ New Denoiser, in the Direct Lighting section. I love this feature but we don’t want it in this scenario.

In this example I’ve set my subsurface settings as such. I’m just cranking things up as a general strategy. Full disclosure I am not an expert on these settings:

With the rt mode, allowing more time for things to fall into place is part of what will give you this additional image detail. Raytracing settle latency. If you want to in the end render out a movie capture sequence with these more resource hungry settings, you will have to determine the ideal settle latency setting. Yes this is going to add some time to the render vs just a settle latency of zero. Maybe try starting out with an SL setting of 50, and increase from there after testing if it seems to make any difference. At a certain point, too much settle latency will create diminishing returns and become pointless, so its really going to depend on your hardware, resolution, the weight of your scene etc etc etc

I spent time experimenting with many different hdri’s trying to find something that was complimentary. Here is the sample I have currently. Let’s focus on skin for now and not worry about issues with the eyebrows/hair/scalp line, we will get to all of that later, although I do want to see if its possible to improve the hair results by working with the omnihair shader.

Again just a v1 sample here, completely different lighting conditions etc so its not the most direct comparison to your test above Pekka. Just where I’m at with this so far.

BONUS TIP: I think there is an issue with the tearline shaders that come out of iclone after conversion. It seems as though a shader is there but it remains invisible in both rt or pt mode. Correct me if I’m mistaken. My solution is to just drop the bundled water shader from the Composer material library onto these objects.

1 Like

For the Kevin it works even better!
The native RTX Realtime was so good I had only just a bit of hacked Path-Traced render over it. Thanks @deeplerning

If anyone has ideas to improve this, please drop a message here!

1 Like

Another way to “hack” this RT SSS shader.
I borrowed new A2F example character Claire´s complex material and just replaced the most obvious texture maps from CC4 Camilla export.

Wow, it looks kinda good, what do you think? No post efx on this render.
If there is someone who knows better about the superior Claire RT shader, please write your thoughts, I would love to try to transport this shader in full effect, with all the texture maps in use…

Great stuff

I think it depends on what you are after. If realistic, the maps have to give certain quality and the shader will take care of the rest

If is more hyper real stylized, then you can tweak the shader bit more to achieve the look you want.

You can see all this in realtime as you tune so get the exact look you want quicker.

look forward to seeing more

1 Like