Change docker image storage location to NVMe SSD

Hi, (Jetpack 4.4)

I am running my Deep Learning with the Nvidia ML docker container. With a new NVMe SSD installed on the Jetson, I would to take advantage of it’s speep by changing the docker image storage location.

That would be a quick win for me now as I do not have time, right now, to try to make the Jeston Xavier boot from the SSD.

Thanks
Simon

Hi @simon.glet, you can do this by setting the "data-root" variable in your /etc/docker/daemon.json configuration file:

"data-root": "/your/NVME/docker/data",

You will also need to have your NVME automatically mounted at boot (i.e. by adding it to /etc/fstab), otherwise it won’t be mounted for the Docker daemon to begin using it.

Thanks @dusty_nv :-)

I will try it in the next couple of days and let you know.

Hi @dusty_nv , I was looking a solution to do the same and I tried changing the data-root in the file daemon.json, then I restarted the daemon but sudo docker info continues given “/var/lib/docker” directory as root-dir. Also I tried the next guide from https://r00t4bl3.com/post/how-to-move-docker-data-directory-to-another-location-on-ubuntu and it didn’t work for me too.
Thanks
Christian

Hi @dusty_nv and @christ.pz.cs,

After installing the NVMe SSD, formating, auto mounting and moving /var/lib/docker to /mnt/ssd_0, this worked for me (/etc/docker/daemon.json):

{
“data-root”: “/mnt/ssd_0/docker”,
“runtimes”: {
“nvidia”: {
“path”: “nvidia-container-runtime”,
“runtimeArgs”:
}
}
}

Cheers
Simon

1 Like

Thanks @simon.glet, it worked!!
Christian