Changing CUDA version

Hi,

Sorry if this is an extremely trivial question …

I am currently trying to compile an example fortran code with cuda

Host code:

program incTest
use cudafor
use simpleOps_m
implicit none
integer, parameter :: n = 256
integer :: a(n), b, i
integer, device :: a_d(n)

a = 1
b = 3
a_d = a
call inc<<<1,n>>>(a_d, b)
a = a_d
if (all(a == 4)) then write(,) ‘Success’ endif end program incTest

Device Code:

module simpleOps_m
contains
attributes(global) subroutine inc(a, b)
implicit none integer :: a(:)
integer, value :: b
integer :: i
i = threadIdx%x a(i) = a(i)+b
end subroutine inc
end module simpleOps_m

To compile I type:

pgf90 -w -gpu=cc30 -cuda inctest_cuda.f90 -o inc.e

Which gives the error:

pgfortran-Error-The -gpu=cc30 option is no longer supported

From what I could gather CUDA 11 does not support the CC30 flag anymore, but CUDA 10.1 should still support CC30. I downloaded NVIDIA HPC SDK Version 20.7 which includes CUDA 10.1, but I still get the same error. Should it be working? Do I have to specify somehow that CUDA 10.1 should be used instead of 11.0? I can’t find anyway to change the CUDA version in with HPC SDK, but I could be missing something very trivial.

I need the -gpu=cc30 flag because I have a GeForce GTX 760M, if I use a different flag it compiles, but the device is not doing the correct operations. I think it would work if I manage to use the cc30 flag, unless the error is somewhere else. Any ideas?

Thank you!