Configuring CUDA cards


I have 2x 9800GTX+ and an 8400 in my computer running RHEL 5.3. I am using the 8400 for display and the 9800s as GPUs. The OS appears to be treating all three cards as available GPUs. Each card shows up as a GPU in nvidia-settings. Is there a way to configure a single card to not be seen as a GPU?



you can use nvidia-smi to set the 8400 as prohibited so no compute context can be created on that device, but there’s no way to simply hide it. (well, not yet. :) )

Thank you very much. When I get to work today, I’ll try using nvidia-smi.