Creating a Real-Time License Plate Detection and Recognition App | NVIDIA

I am trying to “Convert the encrypted LPR ONNX model to a TLT engine”, however, in running the command:
./tao-converter -k nvidia_tao -p image_input,1x3x48x96,4x3x48x96,16x3x48x96 ./us_lprnet_baseline18_deployable.etltunpruned.etlt -t fp16 -e /opt/nvidia/deepstream/deepstream-5.0/samples/models/LP/LPR/lpr_us_onnx_b16.engine
I am receiving the error:
Error: no input dimensions given
I download the latest version “jetpack4.6”, and I can run the command : ./tao-converter -h.
I have tried adding ‘-d 1,3,48,96’ to the command , but it fails, too. Can you help me with this error?

Moving to TAO forum.

Please check if the file is correct.

I found the error. Thank you. However, another issue happen.
[ERROR] Number of optimization profiles does not match model input node number.
Aborted (core dumped)

Please share full command and full log.

command: ./tao-converter -k nvidia_tao -p image_input,1x3x48x96,4x3x48x96,16x3x48x96 us_lprnet_baseline18_deployable.etlt -t fp16 -e /opt/nvidia/deepstream/deepstream-5.0/samples/models/LP/LPR/lpr_us_onnx_b16.engine
output:
[INFO] [MemUsageChange] Init CUDA: CPU +230, GPU +0, now: CPU 248, GPU 1864 (MiB)
[INFO] [MemUsageSnapshot] Begin constructing builder kernel library: CPU 248 MiB, GPU 1865 MiB
[INFO] [MemUsageSnapshot] End constructing builder kernel library: CPU 277 MiB, GPU 1895 MiB
[INFO] ----------------------------------------------------------------
[INFO] Input filename: /tmp/file7zDQGP
[INFO] ONNX IR version: 0.0.0
[INFO] Opset version: 0
[INFO] Producer name:
[INFO] Producer version:
[INFO] Domain:
[INFO] Model version: 0
[INFO] Doc string:
[INFO] ----------------------------------------------------------------
[ERROR] Number of optimization profiles does not match model input node number.
Aborted (core dumped)

The key is wrong. Please change to

-k nvidia_tlt

Problem solved. BTW, I copy the command from the instruction. Thank you very much.

1 Like

Sorry for the inconvenient. We need to update it. The key is not expected.

“Copy the folder of lpr-test-sample to your device and build the code.” (the folder called deepstream-lpr-app) after this instruction, I fail to use the command “make” with this error:
cc -o deepstream-lpr-app deepstream_lpr_app.o deepstream_nvdsanalytics_meta.o pkg-config --libs gstreamer-1.0 -L/opt/nvidia/deepstream/deepstream-5.0/lib/ -lnvdsgst_meta -lnvds_meta -lm -lstdc++ -Wl,-rpath,/opt/nvidia/deepstream/deepstream-5.0/lib/
/usr/bin/ld: cannot find -lnvdsgst_meta
/usr/bin/ld: cannot find -lnvds_meta
collect2: error: ld returned 1 exit status
Makefile:67: recipe for target ‘deepstream-lpr-app’ failed
make: *** [deepstream-lpr-app] Error 1

I can’t find the way to download this library on the net.

Sorry for late reply. Could you try to follow GitHub - NVIDIA-AI-IOT/deepstream_lpr_app: Sample app code for LPR deployment on DeepStream ?