CSI Camera issue in Jupyter lab


I’m having some difficulty with my Jetson nano. I have a Jetson Nano 2GB. It is installed with Jetpack4.5.1.

I am trying to get the classification_interactive.ipynb notebook to work as part of the “Getting started with AI on Jetson Nano course”

When I run the second cell I get the error in the attached text file(CSI_Camera_Error).

I’m not sure if this information is helpful or not, but prior to me running jupyter notebook container I use the command “nvgstcapture-1.0” and I am able to display a live image, but after I shutdown the container and try to run the same command it seems to execute properly except that it does not display an image.

I thought that the camera was not being released, but I tried shutting down all kernels in Jupyter lab, and then restarting the notebook, but I get the same error.

I have attached the log files that I believe may be pertinent.

CSI_Camera_Error (1.2 KB)
Dmesg (57.9 KB)
syslog (299.0 KB)

Try to kill nvargus-daemon and relaunch it then try the launch camera again.

sudo systemctl restart nvargus-daemon

Thanks for the help. I’m not sure if this is working or not. I am having a lot of other problems trying to get the example notebook Classification_interactive.ipyn to work.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.