CUDA 8.0 cannot install on TX1 and has an error

Hi
I have an error installing jetpack 3.1 to Nvidia TX1.CUDA in jetpack cannot connect to tx1, here is error message:

Connection to 192.168.182.83 closed
dpkg-query: package cuda-toolkit-8-0 is not installed and no information is available
dpkg-query: package libfreeimage-dev is not installed and no information is available
dpkg-query: package libopenmpi-dev is not installed and no information is available
dpkg-query: package openmpi-bin is not installed and no information is available
Use dpkg --info (= dpkg-deb --info) to examine archive files,
And dpkg–contents (=dpkg-deb --contents) to list their contents.
1
Error:CUDA cannot be installed on device. This may be caused by other apt-get command running on device when installing CUDA, Please use apt-get command in a terminal to make sure following packages are installed correctly on device before continuing:
cuda-toolkit-8-0 libfreeimage-dev libopenmpi-dev openmpi-bin
After these packages are installed on device, press Enter key to continue

I guess my host Ubuntu version is 14.04, but Jetpack 3.1 need to host Ubuntu 16.04. Otherwise, my tx1 ubuntu version is 14.04, but when I following the jetpack 3.1 installation steps, and my tx1 renew 16.04. Can cuda 8.0 install on only 16.04 on host? If I install old jetpack version to host(ex: jetpack 2.3.1), can solve this problem?

Hi,

JetPack3.1 support Ubuntu14.04 host.

From the error log, you are running apt-get on other applications.
Could you check the functionality of apt-get on our environment first?

Thanks.

Hi

I try to install package first, and run jetpack again.It still has the same error

sudo apt-get install cuda-toolkit-8-0 libfreeimage-dev libopenmpi-dev openmpi-bin

and it does not have the installation at the same time

Tkanks.

Hi,

Want to clarify some details first:

  1. Your x86 host machine is Ubuntu14.04
  2. Try to install TX1 with JetPack3.1. So the TX1 OS version is Ubuntu16.04.

Is this correct?

Besides CUDA package, please make sure you also flash the device with JetPack3.1. (rel-28.1)
Thanks.

Hi,

1.yes, and I use ubuntu operation system computer,not VM ubnutu
2.yes,after I install Jetpack 3.1, TX1 version 14.04 turn into 16.04

thanks

Hi,

It looks like apt-get is broken somehow in your environment.
Could you try to reflash it again?

Please let us the results.
Thanks.

Hi:

I can`t find any problem concerning apt-get command on my ubuntu
Later, I improve my ubnutu from 14.04 to 16.04
and try again to install packages from the error message
$sudo apt-get install cuda toolkit-8-0 libgomp1 libfreeimage-dev libopenmpi-dev openmpi-bin
Reading package lists… Done
Building dependency tree
Reading state information… Done
libfreeimage-dev is already the newest version(3.17.0+ds1-2).
libopenmpi-dev is already the newest version(1.10.2-8ubuntu1).
openmpi-bin is already the newest version(1.10.2-8ubuntu1).
libgomp1 is already the newest version(5.4.0-68ubuntu1-16.04.5).
cuda-toolkit-8-0 is already the newest version(8.0.34-1).
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

and I try to install jetpack again and have the same error,what`s wrong?

thanks

Hi,

In case there are some differences in our comprehension.
Could you check our JetPack tutorial first:
https://www.youtube.com/watch?time_continue=385&v=RJkOGMC8IrY

And run the procedure mentioned in the video to check if the error still occurs?
Thanks.

Hi:
I follow the installing jetpack procedure, and I have the error in 4:38. I have the error concerning apt-get, thanks.

Hi,

In case of a broken package, could you delete all the download package and try it again?
If you still meet the same error, please upload the complete log file for our checking.

$ zip log.zip [Jetpack]/_installer/logs
Attach log.zip

Thanks.

Hi, Has this problem been resolved? Do we know what is the cause?

I’m seeing the same problem. Basically one line in the file ~/cuda-l4t/cuda-l4t.sh cannot be executed successfully:

sudo apt-get -y --force-yes install cuda-toolkit-$3 libgomp1 libfreeimage-dev libopenmpi-dev openmpi-bin

Now I can install the first two packages individually, but not the libopenmpi-dev and openmpi-bin, thus not cuda-toolkit-8-0 either.

root@tegra-ubuntu:~/cuda-l4t# apt-get install libopenmpi-dev openmpi-bin
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 libopenmpi-dev : Depends: libopenmpi1.10 (= 1.10.2-8ubuntu1) but it is not going to be installed
                  Depends: libibverbs-dev (>= 1.1.7) but it is not installable
                  Depends: libhwloc-dev but it is not going to be installed
 openmpi-bin : Depends: libopenmpi1.10 but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

If I follow the first dependency, eventually it hits an unknown package:

root@tegra-ubuntu:~/cuda-l4t# apt-get install  libopenmpi1.10
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 libopenmpi1.10 : Depends: libhwloc5 (>= 1.11.2) but it is not going to be installed
                  Depends: libibverbs1 (>= 1.1.2) but it is not installable
                  Recommends: openmpi-bin but it is not going to be installed
E: Unable to correct problems, you have held broken packages.
root@tegra-ubuntu:~/cuda-l4t#
root@tegra-ubuntu:~/cuda-l4t# apt-get install  libhwloc5
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 libhwloc5 : Depends: libnuma1 but it is not installable
             Recommends: libhwloc-plugins but it is not going to be installed
E: Unable to correct problems, you have held broken packages.
root@tegra-ubuntu:~/cuda-l4t# apt-get install  libnuma1
Reading package lists... Done
Building dependency tree
Reading state information... Done
Package libnuma1 is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

E: Package 'libnuma1' has no installation candidate

The same if I try to install the 2nd dependency required by libopenmpi1.10:

root@tegra-ubuntu:~/cuda-l4t# apt-get install libibverbs-dev
Reading package lists... Done
Building dependency tree
Reading state information... Done
Package libibverbs-dev is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

E: Package 'libibverbs-dev' has no installation candidate

Here is my apt policy output:

root@tegra-ubuntu:~/cuda-l4t# apt-cache policy
Package files:
 100 /var/lib/dpkg/status
     release a=now
 500 http://ports.ubuntu.com/ubuntu-ports xenial-security/universe arm64 Packages
     release v=16.04,o=Ubuntu,a=xenial-security,n=xenial,l=Ubuntu,c=universe,b=arm64
     origin ports.ubuntu.com
 500 http://ports.ubuntu.com/ubuntu-ports xenial-security/main arm64 Packages
     release v=16.04,o=Ubuntu,a=xenial-security,n=xenial,l=Ubuntu,c=main,b=arm64
     origin ports.ubuntu.com
 500 http://ports.ubuntu.com/ubuntu-ports xenial-updates/multiverse arm64 Packages
     release v=16.04,o=Ubuntu,a=xenial-updates,n=xenial,l=Ubuntu,c=multiverse,b=arm64
     origin ports.ubuntu.com
 500 http://ports.ubuntu.com/ubuntu-ports xenial-updates/universe arm64 Packages
     release v=16.04,o=Ubuntu,a=xenial-updates,n=xenial,l=Ubuntu,c=universe,b=arm64
     origin ports.ubuntu.com
 500 http://ports.ubuntu.com/ubuntu-ports xenial-updates/main arm64 Packages
     release v=16.04,o=Ubuntu,a=xenial-updates,n=xenial,l=Ubuntu,c=main,b=arm64
     origin ports.ubuntu.com
 500 http://ports.ubuntu.com/ubuntu-ports xenial/multiverse arm64 Packages
     release v=16.04,o=Ubuntu,a=xenial,n=xenial,l=Ubuntu,c=multiverse,b=arm64
     origin ports.ubuntu.com
 500 http://ports.ubuntu.com/ubuntu-ports xenial/universe arm64 Packages
     release v=16.04,o=Ubuntu,a=xenial,n=xenial,l=Ubuntu,c=universe,b=arm64
     origin ports.ubuntu.com
 500 http://ports.ubuntu.com/ubuntu-ports xenial/main arm64 Packages
     release v=16.04,o=Ubuntu,a=xenial,n=xenial,l=Ubuntu,c=main,b=arm64
     origin ports.ubuntu.com
Pinned packages:
root@tegra-ubuntu:~/cuda-l4t#

Hi minghua.chen,

We have tried to install libopenmpi1.10 manually, and no error occurs.
Could you reflash your device with JetPack3.1 and install CUDA again?

Thanks.

Hi, AastaLL,

Thanks for the verification. We’ll try JetPack3.1 if we are blocked by the problem later. We are using JetPack 2.3 at the moment due to many stuffs those were built at an earlier time.

We eventually figured out a work-around: After flashing the kernel and rootfs/drivers, comment out all the update sources from the /etc/apt/sources.list file, leave only one original source to install packages from. We think one of those update repositories are causing the problem though not sure.

Thank you again.

Hi,

JetPack3.1 is already on Ubuntu-16.04; there are lots of different to Ubuntu14.04 which is contained in JetPack2.3.
It’s recommended to use JetPack3.1 to get the latest OS version.

Thanks.