I can’t find the harmony of these three.
nvidia-smi shows cuda is 12.0. It doesn’t change when I install 11.2. This link does not say which cudnn to install for cuda 12.0. my visual studio version 2022.
Build from source  |  TensorFlow I haven’t slept for days. Please, help help…

I was able to solve the problem. Thank you for the answer.

I think I am facing the same problem, which occurred after the drivers of my GPU got updated (at the end of January 2023). After that Tensorflow and Pyhton do not recognise the GPU although nvidia-smi shows the right model. Before the driver update I had CUDA Toolkit 11.2 installed and nvidia-smi showed it also, afterwards nvidia-smi shows12.0, but Pyhton shows 11.2. I tried today to install older drivers, but it did not help.

I would like to ask you to share your solution, since like you, I also cannot sleep.

Hello :) , I downgraded Tensorflow 2.10.0 to 2.9.
Python version 3.8
conda install -c conda-forge cudnn=8.1
CUDA 11.2
print(‘gpu name’,tf.config.list_physical_devices(‘GPU’)) # for test

Have you tried these ?

Is the problem solved ?