Cuda for 6GB GTX 780?

This doesn’t seem to be supported yet. (I tried cards from two different companies, in three different systems that work fine with the Titan, GTX 750TI, and other cards. I tried Cuda 6.0 and 5.5, and various drivers including the beta one.)

Any idea on a time frame for this to be supported? Thanks.

I’m pretty sure it’s supported.

  1. Start with a supported linux distro for CUDA 6:

http://docs.nvidia.com/cuda/cuda-getting-started-guide-for-linux/index.html#system-requirements

  1. Download and install a proper driver, e.g.:

http://www.nvidia.com/download/driverResults.aspx/76749/en-us

  1. run

nvidia-smi -a

to validate that the driver install is working correctly

  1. Download an appropriate Linux CUDA toolkit runfile installer:

https://developer.nvidia.com/cuda-downloads

  1. Run the installer runfile as root, selecting “no” when prompted to install a driver. Accept/acknowledge other statements about unsupported configuration, etc.

  2. Update system paths approrpriately, as instructed, eg. PATH and LD_LIBRARY_PATH

  3. Make the samples

  4. test run some of the samples, especially deviceQuery

Use the linux getting started document as a guide (use runfile installer method, not package manager method):

http://docs.nvidia.com/cuda/cuda-getting-started-guide-for-linux/index.html#axzz36oF7hXSV

If you’re having trouble with the above sequence, be specific about what step didn’t seem to work correctly, and what you saw displayed.

Thanks, but I’m using Windows 7. As I said, a lot of different cards work fine on my systems, just now these new ones.

I did try Ubuntu 14.04 LTS, but that also is not supported yet…

What is the brand and model of the GTX 780 you tried?
What are the exact driver versions you have tried? I would suggest using CUDA 6.0 with the latest WHQL drivers (which should be newer than the drivers that shipped with CUDA 6.0).
What is the exact version of Windows 7 (Professional, Ultimate etc) you are using? 32-bit or 64-bit?

I see that CUDA 6.5 RC just posted (for registered developers). You might want to give it a try:

https://devtalk.nvidia.com/default/topic/760148/announcements/cuda-6-5-release-candidate-now-available/

Thanks for the response. I’m using Win 7 64-bit, both Home Premium and Pro versions (I’ve tried this in 3 systems). The cards used were:
“EVGA|06G-P4-3787-KR GTX 780”
and
“zotac zt-70210-10p gtx780 6gb ddr5 384bit”

I tried the latest WHQL drivers.

I’m reluctant to spend more time trying CUDA 6.5 RC unless their is some reason to think it will work.

IMHO, the most likely thing is that the 6GB GTX 780 has just “slipped though the cracks” with someone forgetting to fix up CUDA to tell it that this is acceptable hardware.

P.S. The exact drivers tried are:
337.88 WHQL
and
340.43 BETA

These cards (and drivers) work fine for driving monitors, the problem is that CUDA says the hardware is not supported.

The “latest whql drivers” is a statement that reflects a different driver, depending on timeframe. It would be useful to know actually which driver version you used.

Also it would be useful to understand what sequence you followed. In general, the sequence should be something like this:

  1. Install an appropriate driver, that is at least 331.xx or newer.
  2. Run nvidia-smi to validate the driver installation.
  3. Download the Win7 64 bit CUDA 6 toolkit installer
  4. Run the installer, deselect the option to install the driver, and then proceed with installation.

If you run those steps, it should work. If it does not, providing some description of exactly what transpired would be useful, if you want others to help you.

The driver is the only thing that is aware of hardware specifics. CUDA toolkit is generally unaware of hardware specifics beyond compute capability and type (Tesla, Quadro, GeForce). It is not aware of the difference between GTX 780, 780 Ti, and 780 6GB, for example. All those devices use a similar underlying cc 3.5 GPU ASIC. If your driver supports the device, and is a new enough version to be recognized by the CUDA toolkit, that is all that should be necessary. The CUDA toolkit, whether Linux or windows, is not updated each and every time a new device appears, so your statement about “someone forgetting to fix up CUDA” is not an accurate conjecture.

The only real question mark in my mind is the installer itself. Again, this is not updated each and every time a new device is introduced, but it’s impossible to rule out bugs. Therefore, some crisp description of what you observed, beyond “not supported” would be helpful.

Thanks for the interesting insights about the CUDA and driver interactions. I don’t want to play around more with Linux right now, but this is what happens with Windows 7:

Typical scenario: Shut down Win 7 Pro system with EVGA Titan card that is working fine with CUDA 6.0
installed.

Install EVGA 6GB GTX 780 card and restart. As Win 7 starts up again, it installs “Nvidia high resolution auto device driver”. A check of the device manager shows it found the GTX 780 and says it is working properly. The driver is version 9.18.13.4043, dated 6/12/2014.

I try to run one my test programs (that worked fine with the TITAN) that uses JCUDA to call CUDABLAS
routines. The first CUDABLAS call is cublasCreate(handle) and returns error code 1.

I try to re-install CUDA using the package 6.0.37_winvista_win7_win8.1_general_64. The installer extracts to the default directory and starts up saying “checking system”. It then return a yellow triangle and the message “This graphics driver could not find compatible graphics hardware. You may continue installation, but will not be able to run CUDA applications.” Sure enough, if you continue,
CUDA still doesn’t work. BTW, the device manager at this point says the driver version is still the one listed above.

On that machine with the 6GB GTX 780 card and 340.43 driver (9.18.13.4043), can you run

nvidia-smi -a

from a command prompt, and post the results here?

If nvidia-smi is not found can you try to use windows file explorer find function to locate it. If it can’t be located, please download the 340.43 driver from here:

http://www.nvidia.com/download/driverResults.aspx/76513/en-us

and reinstall, then run nvidia-smi -a.

Thanks.

From an Administrator command prompt, running nvidia-smi -a returns:
“Failed to initialize NVML: Unknown Error”

Just curious, do you know if ANYONE, ANYWHERE has gotten this card to work under Windows, for CUDA programs?

I do not know the answer to your question. I’m not trying to waste your time, so if you feel this is not useful, please just ignore me, and I will go away.

The nvidia-smi response is what I expected, as it explains pretty much everything else you are seeing (for example when you remove the “working” Titan card and put in the “failing” 780 6GB card.)

This normally means the driver is not installed correctly.

I’d encourage you to download the 340.43 driver I previously linked, and install it, even though it looks like it is installed already. When you run the installer, please look for and select the checkbox that says “Do a clean install”

After that is complete, reboot, and re-run the nvidia-smi -a test from an elevated command prompt, and see if the results are any different.

Or ignore me and I will stop bothering you.

I appreciate your help and certainly don’t want to waste your time either. The reason I asked about whether you were aware of any other testing of the card/CUDA combination is that it could be really helpful for trouble-shooting. I know there are critics of Nvidia’s pricing and marketing policies, who would just say that Nvidia doesn’t want this combo to work (for some period of time) in order to preserve sales of more costly hardware, but I assign this a very low (although finite) probability.

Anyway, I re-downloaded and re-installed 340.43. It tests system compatibility and gives a green check mark. There is NO obvious option offered for a “clean re-install”, it just asks me to agree to the license terms, and proceeds to do the install. The screen goes black for an instant during the process, and eventually the install finishes with all green check marks.

The nvidia-smi -a command returns the same result as before.

I then tried re-installing CUDA 6.0, and got the usual yellow warning triangle and message that the graphics driver could not find compatible hardware.

Just for fun I next downloaded the CUDA 6.5 RC, and tried installing that. It installed fine without giving the yellow triangle warning and got my hopes up! However, the nvidia-smi -a command returns the same result as before. CUDA doesn’t seem to work in my tests either, but it could be that the JCUDA 6.0 wrappers are not compatible with CUDA 6.5.

We located an EVGA GTX 780 6GB product. We had no trouble loading the 340.43 driver on it in a Win7-x64 environment. Both CUDA 6.0 and CUDA 6.5 are able to be installed, and samples from both CUDA 6.0 and CUDA 6.5 run correctly.

Here is the output from nvidia-smi:

C:\Program Files\NVIDIA Corporation\NVSMI>nvidia-smi.exe
Mon Jul 21 00:33:29 2014
±-----------------------------------------------------+
| NVIDIA-SMI 340.43 Driver Version: 340.43 |
|-------------------------------±---------------------±---------------------+
| GPU Name TCC/WDDM | Bus-Id Disp.A | Volatile Uncorr. ECC |
| Fan Temp Perf Pwr:Usage/Cap| Memory-Usage | GPU-Util Compute M. |
|===============================+======================+======================|
| 0 GeForce GTX 780 WDDM | 0000:01:00.0 N/A | N/A |
| 39% 30C P8 N/A / N/A | 6088MiB / 6143MiB | N/A Default |
±------------------------------±---------------------±---------------------+

±----------------------------------------------------------------------------+
| Compute processes: GPU Memory |
| GPU PID Process name Usage |
|=============================================================================|
| 0 Not Supported |
±----------------------------------------------------------------------------+

I suspect your machine has some kind of software issue.

The only suggestion I can make at this time is to try installing the 340.43 driver, but use a “clean install”. This requires you to select the “Custom (Advanced)” install options. If you’re unsure about this, please review this document:

http://nvidia.custhelp.com/app/answers/detail/a_id/2900/~/guide-on-how-to-install-the-nvidia-display-driver-under-windows-7%2Fwindows-vista

Hi taw,

Swapping GPUs can leave the Windows Registry a bit confused (e.g. see this post ).

Which explains why “reinstalling Windows” so often fixes such problems :-(