CUDA Support Problem (GeForce GTX660)

Hi there,
I have GeForce GTX 660. I installed the CUDA version 11.0. But I got the error CUDA error at bodysystemcuda_impl.h:281 code=13(cudaErrorInvalidSymbol) “setSofteningSquared(softeningSq)”.
I searched online and saw that some cards are not supported with new CUDA versions. Is it the problem I am encountering? I tried to find which CUDA versions support my card but I couldn’t find anything. I could only find the webpage below.


How can I find out which CUDA version supports my card?
Thanks in advance

Hi @seulusoy
You can look at Nvidia Driver & CUDA versions with this link.
What is your Nvidia Driver version?

https://docs.nvidia.com/deploy/cuda-compatibility/index.html#binary-compatibility__table-toolkit-driver

Thank you for quick reply.
I am sorry for replying late. I was trying different versions of CUDA with different versions of Ubuntu. Than I found the following wikipedia page


and release notes of CUDA 11.0
(https://docs.nvidia.com/cuda/archive/11.0/cuda-toolkit-release-notes/index.html#title-new-features)
in wikipedia, it is stated that Kepler is partially supported in CUDA 11. And in release notes, it is stated that sm_30 architecture (architecture of GTX 660) is deprecated since CUDA 10.2.

As a result, I successfully solved the problem by installing CUDA 10.0 on Ubuntu 16.04.

Glad to hear that !!