Cudnn 7 for CUDA 8.0 to build pythorch v1.1.0

Dear all,

I am trying to build pytorch v1.1.0 with CUDA 8.0.
I can’t update CUDA because the changes should be distributed along more than a 100 tx1 boards by script. I think that changing the CUDA in an “unnatended” mode can be dangerous.

So I would need the libcudnn v7 library for CUDA 8.0 in aarch64 architecture (for tx1). I have search along the forum and many other sources and I am not able to find it.

Has anyone manged to get it at some point? I know that this is really old, but…

Thanks so much, any help is appreciated.


1 Like


Please check this with the PyTorch team to see if v1.1.0 can work with CUDA 8.0 first.
They might need some APIs that only supported in the newer CUDA version



Thanks for your response. Yes, actually i mange to build it without cudnn. But I would like to compile pytorch with cudnn to accelete the inference.

Thanks again.

Hi @manelguz7, as @AastaLLL pointed out I’m not sure which versions of CUDA/cuDNN that PyTorch v1.1.0 supports since it’s an older version, but have you tried the PyTorch 1.1 wheels or build instructions from this thread? PyTorch for Jetson

Thanks @dusty_nv for your response!.

Yes, I have already check that. Unfortunetly the distributed system is python3.5 and there no prebuild wheel for that.
In any case I have already build the wheel for pytorch 1.1.0 and torchvision 0.4.2 for my system without cudnn.
However, the question is if someone manage to get a cudnn v7 for cuda 8 in aarch64 (tx1). It would be very appreciated.

Thanks so much!

The only pre-built wheels I have are posted to that thread - perhaps someone else from the community might have one and post it here (although given the age of the versions you are requesting, it seems unlikely - sorry about that). Probably you will need to build it with cuDNN yourself. When you build it, PyTorch will print out a big configuration logging near the begging - check that to make sure it enabled cuDNN before you wait for it to complete the entire build (which takes a while).

Maybe I have not explained my selve, sorry about that.

I have already built Pytoch v1.1.0, from source, without cudnn.
I would like to build Pytoch v1.1.0 with cudnn, by myselve from source, however, the version of cudnn needed for pytorch v1.1.0 is cudnn>7.

What I am asking for is a deb package of a cudnn version = 7.* for CUDA 8 and tx1 (aarch64). I am not able to find it anywhere.

Again, thanks so much for your help.


Regarding the question of @AastaLLL, yes it can work with CUDA 8.0. Is the last version that provide compatibility with CUDA 8.0.

Just in case anyone wonders about.



@manelguz7 what is the version of JetPack-L4T that your Jetson TX1’s are running? There aren’t various versions of CUDA/cuDNN packages available for Jetson/arm64 outside of what comes with JetPack.

The PyTorch v1.1 readme states that it supports “cuDNN v6.x or above” (

However is the issue that you are using cuDNN 8, and PyTorch 1.1 doesn’t support that?
Could you use a newer version of PyTorch that supports the cuDNN that you have?

Hello @dusty_nv ,

The Jetpack version is R28.1.0.
I download the repo of pytorch with version v1.1.0
from git status command:
On branch v1.1.0
Your branch is up-to-date with ‘origin/v1.1.0’.
nothing to commit, working directory clean

And when I tried to build with cudnn v6.0.21, it says:
– Found cuDNN: v6.0.21 (include: /usr/include/, library: /usr/lib/aarch64-linux-gnu/
CMake Error at cmake/public/cuda.cmake:159 (message):
PyTorch requires cuDNN 7 and above.

However, you are right, the documentation says cudnn 6 or higher.

Any hint?



Due to the age of the version of JetPack-L4T you are running, it may be difficult to support the version of PyTorch that you want without upgrading the L4T version of the boards.

Can you try building PyTorch 1.0 instead?

Although you could probably find cuDNN 7 packages in a newer version of JetPack, I don’t think that independently upgrading the cuDNN version would work, because it typically needs updated CUDA and L4T also. So basically you would need to re-flash the boards which I’m not sure is feasible in your situation.

Hello @dusty_nv,

I manage to work with pytorch v1.1.0 without Cudnn. As there are big difference with previouse version (add some segmentation models…) i will go with that version.
If someone can provide cudnn 7.* deb package for tx1 it will be very appreciated.

In the other hand I have the wheel for tx1 for pytorch v1.1.0 and torchvision 0.4 and python3.5 in can someone needed. I would posted it.

Thanks you @dusty_nv and others.


This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.