cuQuantum on Jetson Xavier AGX development kit

I have installed cuQuantum-python 22.05 in a conda python 3.10 environment on a Jetson Xavier AGX development kit with cudatoolkit 11.7. On running python I get:

Traceback (most recent call last):
File “/media/arthurlobo/QML/cuQuantum/python/samples/custatevec/”, line 46, in
handle = cusv.create()
File “cuquantum/custatevec/custatevec.pyx”, line 159, in cuquantum.custatevec.custatevec.create
File “cuquantum/custatevec/custatevec.pyx”, line 173, in cuquantum.custatevec.custatevec.create
File “cuquantum/custatevec/custatevec.pyx”, line 156, in cuquantum.custatevec.custatevec.check_status
cuquantum.custatevec.custatevec.cuStateVecError: CUSTATEVEC_STATUS_NOT_INITIALIZED (initialization error)

Similar errors if I run, etc from the samples directory.

If I run python I get

cuTensorNet-vers: 10001
===== device info ======
GPU-name: Xavier
GPU-clock: 1377000
GPU-memoryClock: 1377000
GPU-nSM: 8
GPU-major: 7
GPU-minor: 2

Include headers and define data types
Define network, modes, and extents
Traceback (most recent call last):
File “/media/arthurlobo/QML/cuQuantum/python/samples/cutensornet/”, line 52, in
A_d = cp.random.random((,), dtype=np.float32)
File “/home/arthurlobo/.conda/envs/qml_py310/lib/python3.10/site-packages/cupy/random/”, line 156, in random_sample
return rs.random_sample(size=size, dtype=dtype)
File “/home/arthurlobo/.conda/envs/qml_py310/lib/python3.10/site-packages/cupy/random/”, line 618, in random_sample
out = self._random_sample_raw(size, dtype)
File “/home/arthurlobo/.conda/envs/qml_py310/lib/python3.10/site-packages/cupy/random/”, line 605, in _random_sample_raw
func(self._generator,, out.size)
File “cupy_backends/cuda/libs/curand.pyx”, line 157, in cupy_backends.cuda.libs.curand.generateUniform
File “cupy_backends/cuda/libs/curand.pyx”, line 161, in cupy_backends.cuda.libs.curand.generateUniform
File “cupy_backends/cuda/libs/curand.pyx”, line 87, in cupy_backends.cuda.libs.curand.check_status
cupy_backends.cuda.libs.curand.CURANDError: CURAND_STATUS_LAUNCH_FAILURE

How can I get cuQuantum to run on the Jetson Xavier AGX?

Your topic was posted in the wrong category. I am moving this to the Jetson AGX category for visibility.

1 Like


Xavier doesn’t have CUDA 11.7 currently.

Please noted that you will need to use the CUDA libraries from the JetPack for the AARCH64 support.
The latest JetPack 5.0.1 includes CUDA 11.4.


This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.